Events pane shows incorrect events after date changed

RESOLVED WORKSFORME

Status

Calendar
Lightning Only
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Alexandre Demers, Unassigned)

Tracking

({regression})

Lightning 1.0b5
All
Linux
regression

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/14.0.793.0 Safari/535.1

Steps to reproduce:

Here is the easiest way to reproduce the problem. Keep TB running and suspend the computer. Then, wake the computer and go back to TB. Go under the Calendar tab and reload remote calendars. Next, go to your mail box and look at the Events pane.


Actual results:

If a long time has passed (i.e. if the computer was suspended for a working day or during a night), the Events pane will not refresh the events list anymore.


Expected results:

Prior, with version 1.0b2, the Events pane would still be able to refresh the events list after a suspend -> reload remote calendar cycle.
(Reporter)

Updated

7 years ago
OS: Other → Linux
(Reporter)

Updated

7 years ago
Summary: Events don't refresh after lost connection/suspend → Regression: Events don't refresh after lost connection/suspend
What type of calendar(s) do you have? Could you enable calendar.debug.log and calendar.debug.log.verbose in the advanced config editor, reload, and check your error console?
Keywords: regression
Summary: Regression: Events don't refresh after lost connection/suspend → Events don't refresh after lost connection/suspend
(Reporter)

Comment 2

7 years ago
I have a personal calendar (local), my Google calendar, my facebook calendar and another ical calendar online from a website (the last three being network calendars). I'll enable the logs and I'll attach them when I'll have reproduce the problem later (it's quite simple to do, I just don't have time right now ;) )
(Reporter)

Comment 3

7 years ago
Hmmm, even when activated, there is no error available to help us.

However, after playing around trying to have an error, I discovered something else that seems related. First, going in suspend mode or disconnecting the network don't seem to be the cause of the problem. The real reason behind the problem is the following: if the date changes, lightning doesn't see it. I discovered it by doing the following:

1- Make sure you have a calendar with events (local or network).
2- Confirm you have them listed in the Events pane.
3- Change the system date manually (that will be the same as going in suspend and reopening the next day).
4- Look at the Events pane: it still shows the list as if nothing changed.

What makes me think Lightning doesn't see correctly a date change are the following steps:
5- Under Calendar tab, look at the mini calendar (upper left): it still shows the date as the old one.
6- Click on any date on the mini calendar: it now changes the current date to the good date.

However, Events pane is still not refreshed. You have to close TB and reopen it to have a refreshed events list to the current (system) date. The behavior was not the same under 1.0b2: when reloading calendars, the Events pane was also reloaded. However, I can't tell for the mini calendar.
(In reply to comment #3)

> 3- Change the system date manually (that will be the same as going in
> suspend and reopening the next day).
Not quite true. We receive a "wake_notification" observer event when the computer comes from the suspend state.
(Reporter)

Comment 5

7 years ago
(In reply to comment #4)
> (In reply to comment #3)
> 
> > 3- Change the system date manually (that will be the same as going in
> > suspend and reopening the next day).
> Not quite true. We receive a "wake_notification" observer event when the
> computer comes from the suspend state.

Thanks for the rectification. Either way, it doesn't get refreshed.
(Reporter)

Comment 6

7 years ago
I'm now using TB5 (release) and the bug is gone. So I'm closing this bug since it was comming from TB and not from Lightning.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

7 years ago
Reopening. The problem is still there in a different form: when passing midnight, the events pane will refresh, but:
1- Only the previous day's events will be listed
2- They are listed under Today (which is wrong since the date changed)
3- All other events disappear

However, going into sleep mode is not a problem anymore, when waking up, events pane will be reloaded correctly (except if the date changed, but this is not related to sleep/wake up as before)
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Updated

7 years ago
Summary: Events don't refresh after lost connection/suspend → Events pane shows incorrect events after date changed
bug 451941 / bug 416099 ?
(Reporter)

Comment 9

7 years ago
(In reply to comment #8)
> bug 451941 / bug 416099 ?

This is different. It really has to do with the Events pane. It's not that TB/Lightning think it is still the previous day as Today. In that case, all events would still appears as they were before midnight.

I'll try to add a screenshot tomorrow of what I mean.
Those bugs are about not all parts of calendar reacting to the change when passing midnight. Looking fwd to your screenshots.

Updated

6 years ago
Duplicate of this bug: 685836

Comment 12

6 years ago
Similar to bug #613844

Comment 13

6 years ago
(In reply to Alexandre Demers from comment #7)
> 1- Only the previous day's events will be listed
> 2- They are listed under Today (which is wrong since the date changed)
> 3- All other events disappear

I've been seeing this bug for a while and have to restart TB each morning.  I don't use hibernation so I agree the problem is with crossing midnight.

TB 5.0 / Lightning 1.0b5rc3 / Kubuntu Linux 11.04 (both 32bit and 64bit)
Version: Trunk → Lightning 1.0b5
(Reporter)

Comment 14

6 years ago
The problem hasn't shown up for some time. I'm now using Lightning 1.0 with TB 8.0. I don't know for Pete, but I would close this bug and reopen it if needed.

Comment 15

6 years ago
(In reply to Alexandre Demers from comment #14)
> The problem hasn't shown up for some time. I'm now using Lightning 1.0 with
> TB 8.0. I don't know for Pete, but I would close this bug and reopen it if
> needed.
I'll test it tonight.  I'm using those same versions of TB and Lightning,

Comment 16

6 years ago
(In reply to Alexandre Demers from comment #7)
> when passing
> midnight, the events pane will refresh, but:
> 1- Only the previous day's events will be listed
> 2- They are listed under Today (which is wrong since the date changed)
> 3- All other events disappear
I agree that this bug is fixed in Lightning 1.0 / TB 8.

Comment 17

6 years ago
Closing from own experience and comment #16.

Thanks for testing again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → WORKSFORME

Updated

6 years ago
Duplicate of this bug: 613844
You need to log in before you can comment on or make changes to this bug.