Closed Bug 668218 Opened 9 years ago Closed 6 years ago

Google+ (Plus) Modal Dialogs Show White Text for Font on OK button

Categories

(Web Compatibility :: Mobile, defect, minor)

ARM
Android
defect
Not set
minor

Tracking

(blocking-kilimanjaro:+)

RESOLVED INVALID
blocking-kilimanjaro +

People

(Reporter: tarend, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [sitewait] [webkitcss] [country-all])

Attachments

(4 files, 1 obsolete file)

Attached image Google+ mobile in Firefox (obsolete) —
Firefox messes up layout of the Google+ mobile page - perhaps due to WebKit-specific code on the web page?

(1) Go to m.google.com/plus on your phone, log in with an account that has Google+ enabled

Result: (see screenshot) - layout is broken, icons show the wrong size, which renders the service impossible to use with Firefox. Layout works well 

Expected: no layout issues
Attached file HTML Source
I attached the HTML source of the page for reference
Attached file Google+ Page Source
I added the actual page source (the attached PDF cut off some HTML) for your reference. Also: viewing the page in desktop Firefox shows the exact same layout issues.
The page served to Firefox for Android uses the following WebKit-only markup without fallbacks for other browsers:

-webkit-animation-duration, -webkit-animation-names, -webkit-animation-timing-function, -webkit-keyframes
-webkit-background-size
-webkit-border-image
-webkit-box, -webkit-box-align, -webkit-box-orient, -webkit-box-sizing
-webkit-tap-highlight-color
-webkit-transition, -webkit-transform
-webkit-user-select

(This list may be incomplete.)
Duplicate of this bug: 682648
Should this be moved to evangelism?  I don't know if there is anything we can do on our side here.
We support almost exact equivalents for all those properties in comment #5 except
* -webkit-box, -webkit-box-align, -webkit-box-orient (there are -moz-box variants, but they might not work the same in all cases)
*  -webkit-tap-highlight-color
Summary: Google Plus Layout broken → Google+ (Plus) Layout broken
This definitely needs to be a Tech Evangelism bug. Google is serving us pages that are designed to only work in Webkit.
Assignee: nobody → english-us
Component: General → English US
Product: Fennec → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified
Let me try to find someone from Google who could help…
Stephen Lau from Google said: "There is already a bug assigned internally for that".
http://twitter.com/#!/stevel/status/114438611931381761

… wait and see.
Attached image Firefox 8
Mostly good except for the nearby/circles bar.
Attachment #542821 - Attachment is obsolete: true
Now it looks mostly ok except for button backgrounds (which causes some buttons to only show up as text).
Assignee: english-us → nobody
Component: English US → Evangelism
Product: Tech Evangelism → Fennec Native
QA Contact: english-us → evangelism
Version: unspecified → Trunk
Depends on: 739832
Device; Samsung Galaxy Nexus
Browser: Fennec Native Nightly
Build Date: 4/3/2012
Website: plus.google.com

Re-tested this. The quality of application outside the buttons issues mentioned in comment 13 are still correct - It's a good experience outside of the button issues. The layout team probably does not need to worry about this (issues are minor).
Summary: Google+ (Plus) Layout broken → Google+ (Plus) Modal Dialogs Show White Text for Font on OK button
Renaming given that the problem now isn't the layout is busted, its just now a minor issue with modal dialogs.
Severity: critical → minor
Priority: P2 → --
No longer blocks: google-evangelism
blocking-kilimanjaro: --- → +
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Trunk → unspecified
Whiteboard: [sitewait][webkitcss]
The last time, this was tested was 2012-04-03. Is the issue still there? It seems a low hanging fruit.
Flags: needinfo?(jsmith)
Whiteboard: [sitewait][webkitcss] → [sitewait] [webkitcss] [country-all]
(In reply to Karl Dubost :karlcow from comment #16)
> The last time, this was tested was 2012-04-03. Is the issue still there? It
> seems a low hanging fruit.

No longer valid - this site looks different. Although the menu is entirely broken - will open a separate bug for this.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(jsmith)
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.