Last Comment Bug 668218 - Google+ (Plus) Modal Dialogs Show White Text for Font on OK button
: Google+ (Plus) Modal Dialogs Show White Text for Font on OK button
Status: RESOLVED INVALID
[sitewait] [webkitcss] [country-all]
:
Product: Tech Evangelism
Classification: Other
Component: Mobile (show other bugs)
: unspecified
: ARM Android
: -- minor (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://m.google.com/plus
: 682648 (view as bug list)
Depends on: 739832
Blocks: google-evangelism
  Show dependency treegraph
 
Reported: 2011-06-29 08:02 PDT by Thomas Arend [:tarend]
Modified: 2013-10-17 13:17 PDT (History)
26 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+


Attachments
Google+ mobile in Firefox (299.93 KB, image/jpeg)
2011-06-29 08:02 PDT, Thomas Arend [:tarend]
no flags Details
HTML Source (84.01 KB, application/pdf)
2011-06-29 08:20 PDT, Thomas Arend [:tarend]
no flags Details
Google+ Page Source (483.60 KB, text/html)
2011-06-29 08:57 PDT, Thomas Arend [:tarend]
no flags Details
Google+ on Safari vs. Firefox (272.55 KB, image/png)
2011-06-29 09:00 PDT, Thomas Arend [:tarend]
no flags Details
Firefox 8 (62.59 KB, image/png)
2011-11-07 17:41 PST, Kevin Brosnan [:kbrosnan]
no flags Details

Description Thomas Arend [:tarend] 2011-06-29 08:02:50 PDT
Created attachment 542821 [details]
Google+ mobile in Firefox

Firefox messes up layout of the Google+ mobile page - perhaps due to WebKit-specific code on the web page?

(1) Go to m.google.com/plus on your phone, log in with an account that has Google+ enabled

Result: (see screenshot) - layout is broken, icons show the wrong size, which renders the service impossible to use with Firefox. Layout works well 

Expected: no layout issues
Comment 1 Thomas Arend [:tarend] 2011-06-29 08:20:19 PDT
Created attachment 542826 [details]
HTML Source

I attached the HTML source of the page for reference
Comment 2 Thomas Arend [:tarend] 2011-06-29 08:57:44 PDT
Created attachment 542832 [details]
Google+ Page Source
Comment 3 Thomas Arend [:tarend] 2011-06-29 09:00:22 PDT
I added the actual page source (the attached PDF cut off some HTML) for your reference. Also: viewing the page in desktop Firefox shows the exact same layout issues.
Comment 4 Thomas Arend [:tarend] 2011-06-29 09:00:56 PDT
Created attachment 542834 [details]
Google+ on Safari vs. Firefox
Comment 5 Matt Brubeck (:mbrubeck) 2011-07-28 11:05:38 PDT
The page served to Firefox for Android uses the following WebKit-only markup without fallbacks for other browsers:

-webkit-animation-duration, -webkit-animation-names, -webkit-animation-timing-function, -webkit-keyframes
-webkit-background-size
-webkit-border-image
-webkit-box, -webkit-box-align, -webkit-box-orient, -webkit-box-sizing
-webkit-tap-highlight-color
-webkit-transition, -webkit-transform
-webkit-user-select

(This list may be incomplete.)
Comment 6 Wesley Johnston (:wesj) 2011-08-27 22:21:08 PDT
*** Bug 682648 has been marked as a duplicate of this bug. ***
Comment 7 :Ehsan Akhgari (busy, don't ask for review please) 2011-09-02 08:05:01 PDT
Should this be moved to evangelism?  I don't know if there is anything we can do on our side here.
Comment 8 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-09-03 06:46:48 PDT
We support almost exact equivalents for all those properties in comment #5 except
* -webkit-box, -webkit-box-align, -webkit-box-orient (there are -moz-box variants, but they might not work the same in all cases)
*  -webkit-tap-highlight-color
Comment 9 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-09-10 06:29:00 PDT
This definitely needs to be a Tech Evangelism bug. Google is serving us pages that are designed to only work in Webkit.
Comment 10 Paul Rouget [:paul] 2011-09-15 13:41:06 PDT
Let me try to find someone from Google who could help…
Comment 11 Paul Rouget [:paul] 2011-09-15 13:43:22 PDT
Stephen Lau from Google said: "There is already a bug assigned internally for that".
http://twitter.com/#!/stevel/status/114438611931381761

… wait and see.
Comment 12 Kevin Brosnan [:kbrosnan] 2011-11-07 17:41:11 PST
Created attachment 572691 [details]
Firefox 8

Mostly good except for the nearby/circles bar.
Comment 13 :Ehsan Akhgari (busy, don't ask for review please) 2012-03-27 15:29:42 PDT
Now it looks mostly ok except for button backgrounds (which causes some buttons to only show up as text).
Comment 14 Jason Smith [:jsmith] 2012-04-03 18:46:52 PDT
Device; Samsung Galaxy Nexus
Browser: Fennec Native Nightly
Build Date: 4/3/2012
Website: plus.google.com

Re-tested this. The quality of application outside the buttons issues mentioned in comment 13 are still correct - It's a good experience outside of the button issues. The layout team probably does not need to worry about this (issues are minor).
Comment 15 Jason Smith [:jsmith] 2012-05-05 15:48:09 PDT
Renaming given that the problem now isn't the layout is busted, its just now a minor issue with modal dialogs.
Comment 16 Karl Dubost :karlcow 2013-10-17 10:35:23 PDT
The last time, this was tested was 2012-04-03. Is the issue still there? It seems a low hanging fruit.
Comment 17 Jason Smith [:jsmith] 2013-10-17 13:17:18 PDT
(In reply to Karl Dubost :karlcow from comment #16)
> The last time, this was tested was 2012-04-03. Is the issue still there? It
> seems a low hanging fruit.

No longer valid - this site looks different. Although the menu is entirely broken - will open a separate bug for this.

Note You need to log in before you can comment on or make changes to this bug.