rip out codesighs logic from buildbot and replace it with a tiny new step

RESOLVED WONTFIX

Status

Release Engineering
General Automation
P3
normal
RESOLVED WONTFIX
7 years ago
4 years ago

People

(Reporter: ted, Assigned: jlund)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [unittest])

(Reporter)

Description

7 years ago
In bug 659950 I implemented a much simpler replacement for our existing codesighs logic. You can now "make codesighs" in the objdir and it will print two metrics, like:
__codesize:40387084
__installersize:17112982

The first is the size in bytes of all the files we install to a user's machine, and the second is the size in bytes of the installer itself.

We should be able to rip out all the codesighs machinery from our buildbot steps and replace it with a simple "make codesighs" + a modified graph server post. bug 668216 is filed on the graph server changes necessary to add the new values.

Presumably this would be easier if my codesighs change landed on all active branches? I think I can arrange for that, since it's NPOTB.

Updated

7 years ago
Assignee: nobody → coop
Priority: -- → P3
Whiteboard: [unittest]
We currently have a single number, Z on tbpl/tinderbox, and 'Codesighs' in the graph server. How should that change/be supplemented for this ?
(Reporter)

Comment 2

7 years ago
We'll have two numbers, I don't really know what the naming will be, but we can argue about that in bug 668216. :)
Duplicate of this bug: 741297

Comment 4

6 years ago
I'll start by adding the new measurements in addition to the existing codesighs, then we can remove codesighs at our leisure.

I made my nomenclature suggestion in bug 668216. Nothing fancy: codesize and installersize.
Status: NEW → ASSIGNED
Priority: P3 → P2
Can this be done so that we can move other build analysis logic into it as well (like num_ctors for example)?

Comment 6

6 years ago
(In reply to Chris AtLee [:catlee] from comment #5)
> Can this be done so that we can move other build analysis logic into it as
> well (like num_ctors for example)?

What do you mean? Batching the num_ctors step with these new ones into a logical bundle?
Yeah, I'd like a single buildbot step that calls out to a script or make target to generate all these stats.
Depends on: 803736

Updated

5 years ago
Status: ASSIGNED → NEW
Priority: P2 → P3

Comment 8

5 years ago
It's pretty clear I'm not making progress on this

I can try to have a new hire or intern pick it up though. Is there any update in how people think this should be implemented?
Assignee: coop → nobody
Component: Release Engineering → Release Engineering: Automation (General)
QA Contact: catlee
(Assignee)

Updated

5 years ago
Assignee: nobody → jlund
Product: mozilla.org → Release Engineering
codesighs is dead
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.