when all columns are removed from a tree, the column picker moves

RESOLVED DUPLICATE of bug 66719

Status

()

Core
XUL
--
minor
RESOLVED DUPLICATE of bug 66719
18 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Steps to reproduce: 
1. Open a tree with a column picker (bookmarks, history sidebar, etc.)
2. Using the column picker, remove all columns.

Result: column picker moves to the left, and the usually gray area where the 
column headers are becomes white.

Expected result: "no columns selected" 'column' appears when no columns are 
selected, or attempting to remove all columns gives an error message.
(Reporter)

Comment 1

18 years ago
This can trigger bug 66832, "column picker menu always appears left of widget", 
which makes it a little tricky to re-add columns if the column picker ends up 
near the left edge of the screen.
(Reporter)

Comment 2

18 years ago
Some columns in the mail thread pane have fixed width.  The plot thickens...
(Reporter)

Comment 3

18 years ago

*** This bug has been marked as a duplicate of 66719 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.