Closed Bug 668526 Opened 9 years ago Closed 8 years ago

Design/Build rackmount solution for tegras

Categories

(Infrastructure & Operations :: RelOps: General, task)

x86
macOS
task
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 666044

People

(Reporter: zandr, Assigned: zandr)

References

Details

In order to make Tegras a tier-one solution, we need to design and build a rackmount solution.

Requirements:
1) Proper airflow
2) no 'waterfall of wall-warts' power supplies
3) remote power management
4) remote imaging for a large percentage of failure modes (bug 665926)
5) stable mechanical mounting

Current thoughts are around a 4U box with a foopy and 14 tegras. 
Two high-current DC supplies to feed the tegras through usb relay boards.
USB for the tegras (and relay boards) connected to the foopy.
On-board unmanaged switch.

Design for enhancement if necessary: 
Add relay boards if pressing buttons remotely is needed. 
  (unfortunate, but reasonable)
Add front panel USB/video connections for crashcarting. 
  (needing this should be considered a failure mode)

14 Tegras + 1 Foopy in 4U gives us a density of 140 Tegras/rack
Blocks: 666044
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 666044
Component: Server Operations: RelEng → RelOps
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.