disabling javascript still loads javascript into cache.

RESOLVED FIXED in Future

Status

()

--
enhancement
RESOLVED FIXED
18 years ago
16 years ago

People

(Reporter: bugs4hj, Assigned: darin.moz)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME?])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
If you disable Javascript, then all external javascript are still loaded and put
into disk cache You may check this behaviour with about:cache, or with an
protocol analyzer, as I did. Can't external Javascripts being blocked with the
help of HTTP filtering. If you don't like Javascript to run for a site, why
should web-surfers still load those files, if they don't want to use them?

Used the correct Severity, for the first time ever, thanks Hakan!

Comment 1

18 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [RFE] disabling javascript still loads javascript. → [RFE] disabling javascript still loads javascript into cache.

Comment 2

18 years ago
Cache bugs to Gordon
Assignee: neeti → gordon
Target Milestone: --- → mozilla1.0

Updated

18 years ago
Assignee: gordon → darin
Component: Networking: Cache → Networking: HTTP

Comment 3

18 years ago
This is really up to http or its clients.
*** Bug 80580 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.0.1 → ---
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Updated

16 years ago
Component: Networking: HTTP → Layout
Summary: [RFE] disabling javascript still loads javascript into cache. → disabling javascript still loads javascript into cache.

Comment 5

16 years ago
Any chance this will be addressed?  For what it's worth, IE 6 doesn't load
scripts if scripting is disabled.  This is obviously more of an issue where
bandwidth is limited.

I used a different (and for me, simpler) approach to determining whether the
browser was requesting the script files: I looked in the server log.

A workaround: load scripts dynamically, using something like the following:

  <script language="javascript" type="text/javascript">
    document.write('<script language="javascript" src="path/script.js"
type="text/javascript"> <\/script>');
  </script>

It's a little scary, but it works on IE 5+, Mozilla 1.4, and Opera 7.11.  (I
haven't tried earlier versions of Mozilla and Opera.)

Comment 6

16 years ago
The workaround mentioned above also works with Mozilla 1.0, 1.1, 1.2.1, and 1.3.
(Assignee)

Updated

16 years ago
Whiteboard: [DUPEME?]
It would be trivial to do a IsScriptEnabled check in the <script> node before
attempting to execute or load scripts... so just change:

648   if (mIsEvaluated || mEvaluating || !mDocument || !mParent) {
649     return;
650   }

To:


648 if (mIsEvaluated || mEvaluating || !mDocument || !mParent ||
!mDocument->IsScriptEnabled()) {
649     return;
650   }
sr=jst
Patch checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 12

16 years ago
*** Bug 219322 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.