No keyboard shortcut for "Get New Messages" (MacOS, TB5.0)

VERIFIED DUPLICATE of bug 655989

Status

Thunderbird
General
VERIFIED DUPLICATE of bug 655989
7 years ago
7 years ago

People

(Reporter: Richard Mlynarik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 543225 [details]
no-get-new-messages.jpg

User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_8; en-us) AppleWebKit/533.21.1 (KHTML, like Gecko) Version/5.0.5 Safari/533.21.1

Steps to reproduce:

"Upgraded" for THunderbird 5.0.

It has been ALL DOWNHILL since version 2.  Only UI disasters have been introduced, and not one single bug that affects me has been fixed.

MacOS 10.6.8
Thunderbird 5.0



Actual results:

Typed command-T (which has meant "Get new mail" for the last 15 years or so.)
Nothing happened.

Then tried to look and see if some simian has reassigned the keyboard shortcut.

I pulled down the "File / Get New Messages >" submenu (which is missing the trailing "..." required by Apple UI, but whatever) and see no evidence of a keyboard shortcut there.

So, it's just gone away.

After all, who would EVER NEED TO GET NEW MAIL without messing around with a mouse and menus?


Expected results:

THe commonest thing I do with Thunderbird should be on a single keystroke.

"Upgrading" Thunderbird should not break the most elementary functionality.
(Die die die die anybody in any way connected with <https://bugzilla.mozilla.org/buglist.cgi?quicksearch=quickfilter>)

Is there any adult in charge anywhere?

Comment 1

7 years ago
The key was changed to [Shift]+F5. Not sure why it's not being shown on Mac...
(Reporter)

Comment 2

7 years ago
Created attachment 543232 [details]
Function keys are simply not part of the Mac UI for Mac users of Mac applications.  End of story.

Perhaps this is a nice keyboard command in MS-DOS or something.

It simply shouldn't be on the table for any MacOS application intended for actual human users.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 655989
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.