Show compatibility error for using nsIDOM3Node in Firefox 7

VERIFIED FIXED in 6.1.6

Status

addons.mozilla.org Graveyard
Compatibility Tools
P3
normal
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: jorgev, Assigned: basta)

Tracking

unspecified
6.1.6

Details

(Whiteboard: [fx7])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
As explained in bug 659053, the nsIDOM3Node interface has been removed. We should flag any instances of this interface.

This should show an error and prevent the add-on from being upgraded.

Message:

The nsIDOM3Node interface has been removed in Firefox 7. Please refer to <LINKED_BUG> for more information.

Krupa:

https://addons.mozilla.org/en-US/firefox/addon/mozilla-archive-format/
(Reporter)

Updated

6 years ago
Assignee: nobody → mbasta
Target Milestone: 6.1.5 → 6.1.6
(Assignee)

Comment 1

6 years ago
Merged:

https://github.com/mozilla/amo-validator/commit/572010cfde71f5728c1adebc4aec0c26387193dc
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 2

6 years ago
verified at https://addons.allizom.org/en-US/developers/addon/mozilla-archive-format/validation-result/38367
Status: RESOLVED → VERIFIED

Comment 3

6 years ago
Created attachment 546942 [details]
post-fix screenshot
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.