Closed Bug 668745 Opened 10 years ago Closed 3 years ago

Firefox full screen on dual monitor lacks one pixel at the bottom

Categories

(Firefox :: General, defect)

8 Branch
All
Windows 7
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 729011

People

(Reporter: x12ozmouse, Unassigned)

Details

(Whiteboard: Problem persists in version 7 and 8)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Set up a dual-monitor configuration, one screen above the other one (secondary on top, primary on bottom). Launch Firefox on the secondary screen in maximized mode.


Actual results:

There is a white line (1px height) on the bottom of the screen that is not taken by the application window, i.e. Firefox maximizes incorrectly.


Expected results:

That empty line should also be taken by Firefox window.
Can you reproduce this with the default theme (ie, in Safe Mode)?
Yes, it is reproducable with the default theme. It's just a bit less noticeable, but annoying while on a dark web-site. Do you need my hardware details?
Please post the graphics section from about:support
Videocard description  NVIDIA GeForce 8400M GS
Vendor code            10de
Device code            0427
Video memory size      256
Video drivers          nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver version         8.17.12.7533
Driver date            5-20-2011
Direct2D enabled       true
DirectWrite enabled    true (6.1.7601.17563, font cache n/a)
Visualizer             WebGLGoogle Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.611)
Hardware accelerated windows 1/1 Direct3D 10


I had to translate the strings, because they were in English.
> I had to translate the strings, because they were in English.
In Russian, sorry.

And, by the way, that stripe started blinking frequently recently.
OS: Other → Windows 7
Whiteboard: Problem persists in version 7 and 8
Version: 5 Branch → 8 Branch
Videocard description		NVIDIA GeForce 8400M GS
Vendor code					10de
Device code					0427
Video memory size			256
Videocard drivers			nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver version				8.17.12.8026
Driver date					8-3-2011
Direct2D enabled			true
DirectWrite enabled			true (6.1.7601.17563)
ClearType settings			ClearType settings not found
Visualizer	 				WebGLGoogle Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)
H/W accelerated windows		1/1 Direct3D 10


Problem persists in versions 7beta1 and 8a2
We also have this problem at work. Because we use a full screen web browser to display slideshows for digital signs we can not use Firefox as the web browser for our digital sign networks.
(In reply to Jason Ross from comment #7)
> We also have this problem at work. Because we use a full screen web browser
> to display slideshows for digital signs we can not use Firefox as the web
> browser for our digital sign networks.

Forgot to say that this problem is present on both Linux and Windows versions of FireFox.
I can confirm that, some line at the bottom on secondary screen.
On single screen when in full screen there is a one pixel (rgb-0,0,0) line at top.
To see this just do a screenshot with white page at fullscreen.
Another way to see this is go to http://ie.microsoft.com/testdrive/Performance/FishIETank/Default.html and hit F11 to full screen, at the right you will se that the screen size will be 1px less at top ex:1280x799px.
Similar thread at the forum:
http://forums.mozillazine.org/viewtopic.php?p=10082711#p10082711 (1280x1023) (1920x1199)
I can also confirm this. It doesn't seem to matter if you have a dual monitor setup, at least for me. I suggest we update the summary.

This problem also occurs in DOM full-screen mode (mozRequestFullscreen). I assume it's the same bug. If not, I can file a separate one.

(Side note: In the IE Fish Tank one can see that the correct height is reached, during the transition to regular fullscreen mode, but then decreased by one px)
(In reply to Daniel from comment #10)
> This problem also occurs in DOM full-screen mode (mozRequestFullscreen). I
> assume it's the same bug. If not, I can file a separate one.

Actually, this only happens if I have sometime in the browsing session entered the regular fullscreen mode. 

STR:
1. Restart browser
2. Go to https://developer.mozilla.org/samples/domref/fullscreen.html
3. Hit enter to go fullscreen
4. Execute "document.getElementById('myvideo').clientHeight;" in the console in windowed mode (open with ctrl+shift+k and choose "Position > Window")
5. Observe correct height
6. Hit esc and then f11 twice to jump in and out of regular fullscreen mode
7. Repeat step 3 and 4
8. Observe incorrect height (-1 px)
Severity: normal → minor
This bug is still present in fullscreen mode. Height is 1 pixel less, than it should be... To verify go to http://whatsmy.browsersize.com/ press F11 and refresh the page with F5.

Please mark the bug at least as confirmed.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 729011
You need to log in before you can comment on or make changes to this bug.