Last Comment Bug 668782 - Add csb and sw to the Firefox build
: Add csb and sw to the Firefox build
Status: VERIFIED FIXED
[merge-day]
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Axel Hecht [pto-Aug-30][:Pike]
:
Mentors:
Depends on: 668773
Blocks: fx-l10n-sw fx-l10n-csb
  Show dependency treegraph
 
Reported: 2011-07-01 05:06 PDT by Axel Hecht [pto-Aug-30][:Pike]
Modified: 2011-12-21 05:24 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
add csb and sw (238 bytes, patch)
2011-07-27 06:46 PDT, Axel Hecht [pto-Aug-30][:Pike]
christian: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Axel Hecht [pto-Aug-30][:Pike] 2011-07-01 05:06:37 PDT
We need to add csb and sw to browser/locales/all-locales on mozilla-aurora.

PS: to be clear to the localization team, this bug is handled by mozilla staff.

Depending on how quickly we get the repo for csb in bug 668773, we can do this in one patch for both sw and csb (sw has a repo already)
Comment 1 Jurk 2011-07-16 01:40:55 PDT
I believe, bug 668773 has been completed so, nothing to do here (?)
Comment 2 Milos Dinic [:Milos] 2011-07-25 13:02:28 PDT
That bug is still missing some info.
Comment 3 Axel Hecht [pto-Aug-30][:Pike] 2011-07-27 06:46:34 PDT
Created attachment 548764 [details] [diff] [review]
add csb and sw

For now, we still need to add locales to both the repository and to buildconfig.

This patch is only intended to land on aurora, and to neither go to central, nor to go to beta.
Comment 4 Brad Lassey [:blassey] (use needinfo?) 2011-07-28 14:21:54 PDT
how does the 3-char locale code play with our locale matching regex's? Has this been tested?
Comment 5 Axel Hecht [pto-Aug-30][:Pike] 2011-07-28 14:34:11 PDT
We already have son, nso, etc.
Comment 6 Axel Hecht [pto-Aug-30][:Pike] 2011-08-08 06:11:01 PDT
Per discussion on the triage meeting, landed this as two patches:
csb: http://hg.mozilla.org/releases/mozilla-aurora/rev/c07180438c0c
sw: http://hg.mozilla.org/releases/mozilla-aurora/rev/bcd02d1735e4
Comment 7 Simona B [:simonab ] -PTO- back Sept 5th 2011-08-19 02:32:40 PDT
What exactly should I do to verify this? Can anyone help?
Comment 8 Nick Thomas [:nthomas] 2011-08-19 04:26:19 PDT
Look for 8.0a2 builds in
  http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-aurora-l10n/

(Can't remove the 7.0a2 ones until we update mozilla.com/channels)
Comment 9 Simona B [:simonab ] -PTO- back Sept 5th 2011-08-19 05:26:53 PDT
I followed the instruction in Comment 8, csb and sw builds are now added. Setting resolution to VERIFIED FIXED.

Thank you Nick for the guidelines.
Comment 10 Axel Hecht [pto-Aug-30][:Pike] 2011-12-16 05:49:43 PST
Just had to push these two to aurora again, because they got lost in the last merge day :-(, http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?changeset=5a476aaaf4d9

Christian, any idea on how to prevent that?
Comment 11 christian 2011-12-16 12:47:52 PST
Add it to the checklist and we'll make sure they stay in (https://wiki.mozilla.org/Releases/Merge_Checklist).
Comment 12 christian 2011-12-21 05:24:48 PST
I made sure to transplant this correctly today

Note You need to log in before you can comment on or make changes to this bug.