alarms disappear currently in lightning 1.0 beta4

VERIFIED DUPLICATE of bug 668450

Status

Calendar
Alarms
VERIFIED DUPLICATE of bug 668450
7 years ago
7 years ago

People

(Reporter: Hannes, Unassigned)

Tracking

Lightning 1.0b4
All
Other

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

I migrated from TB 3.x / Lightning 1.0 beta 2 to TB 5.0 and  Lightning 1.0 beta 4. No changes in settings. I use WinXP SP3.


Actual results:

Alarms disappear in 10th of a second (without a button been clicked). It's only possible to see a shape of a new window - sound ok. 


Expected results:

Alarms should stay on screen until I've read the text and clicked 'remind later' or 'close' button.
Are you sure there are really alarms due? Unfortunately we have a bug where the sound shows up even though there are no alarms, see bug 668450.
(Reporter)

Comment 2

7 years ago
 (In reply to comment #1)
> Are you sure there are really alarms due? Unfortunately we have a bug where
> the sound shows up even though there are no alarms, see bug 668450.

Yes. Its behaviour is different to 668450 and UPDATE: not the same to every event:

For 1st of July 2011 I've three 24h events and one, that starts at 7.00 pm:
1.) repeats monthly, reminds 5min before
2.) repeats every four weeks, reminds 5 days before
3.) repeats every two weeks, reminds 5 days before
4.) repeats monthly, reminds 2 hours before, starts 7.00 pm

Today, 1. July 2011, the alarm for the fourth event did not disappear starting TB at 6.00 pm. The others (I assume) still behave like I described above when I start TB again.

Additionally in the lower pane at the right I cannot see the first three events
that are closed in the past, only closed events of No 4.

Comment 3

7 years ago
I can pretty much confirm the behaviour as Hannes described. Actually I did not test this very extensively but here is what I found. 

I have the following events on my (local) calendar:
- recurring monthly, reminder 5min before
- non-recurring "test" event, reminder 0min before

Now when I start Thunderbird the following happens:
1.) Before the main window appears, the notification window pops up for a spit second (including the sound)
2.) The main window opens
3.) Thunderbird fetches e-mail from all accounts 
4.) The notification window pops up again (including the sound) but ONLY with the non-recurring "test" event

By the way, I also tried disabling all addons except Lightning but this also didn't help.

This behaviour is really annoying because there is currently no way I can ever confirm this recurring event!

By the way here are my system specs:
Windows NT 6.0 with Service Pack 2
Thunderbird 5.0
Lightning 1.0b4

Comment 4

7 years ago
Sounds a little bit like the faulty behavior I described in Bug 491118 Comment 20 when testing the patch. Missed reminders for occurrences of a repeating event fire but are not shown in the popup dialog.
(Reporter)

Comment 5

7 years ago
(In reply to comment #3)
> I can pretty much confirm the behaviour as Hannes described. Actually I did
> not test this very extensively but here is what I found. 
> 
> I have the following events on my (local) calendar:
> - recurring monthly, reminder 5min before
> - non-recurring "test" event, reminder 0min before
> 
> Now when I start Thunderbird the following happens:
> 1.) Before the main window appears, the notification window pops up for a
> spit second (including the sound)
> 2.) The main window opens
> 3.) Thunderbird fetches e-mail from all accounts 
> 4.) The notification window pops up again (including the sound) but ONLY
> with the non-recurring "test" event
> 
> By the way, I also tried disabling all addons except Lightning but this also
> didn't help.
> 
> This behaviour is really annoying because there is currently no way I can
> ever confirm this recurring event!
> 
> By the way here are my system specs:
> Windows NT 6.0 with Service Pack 2
> Thunderbird 5.0
> Lightning 1.0b4

This seems to be another miracle. 
The event I can see the message for is - as the others - recurring too but it starts at 7.00 pm and not at 0.00 am.

In addition: wrong start/end times are shown in the lower pane for closed events (event No 4, see https://bugzilla.mozilla.org/show_bug.cgi?id=668784#c2) during a mouseover action: they all start/end not at the first day of month but at the last of the month before. I do not know if this is another bug or just another symptom of the same bug.
(Reporter)

Comment 6

7 years ago
Errata:

Shame on me! The 4th event mentioned in Comment 2 is a task in my calendar too with the SAME NAME but a day earlier! Ups... Sorry to all for this confusion!

So it's hard to say what message was shown. My bet is on the event because it was the first message I've got and did not disappear currently with Lightning 1.0 beta 4 that I installed when it was released.

All events and the one task I mentioned before are old ones that already existed with earlier versions of Lightning! I get different behaviours with new ones!
Same core issue as in bug 668450 though, as I've just found out. A workaround is available, but you'll have to apply it manually until I release the next version in a few weeks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 668450
(Reporter)

Comment 8

7 years ago
I would appreciate that if you could inform me about your workaround. Does it make sense to publish it somewhere at the 'release notes page'? Everyone who updates TB and uses Lightning will need it.
Please see the mentioned bug. The workaround requires changing the source code, I will post a new release containing the workaround in the next weeks.

Comment 10

7 years ago
The problem seems to be solved with the Lightning 1.0.b5 update. Thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.