Last Comment Bug 668812 - Test harness: run_app needs to handle Firefox command line options bug
: Test harness: run_app needs to handle Firefox command line options bug
Status: RESOLVED DUPLICATE of bug 669791
:
Product: Add-on SDK
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Mac OS X
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-01 07:47 PDT by arky [:arky]
Modified: 2011-07-07 11:37 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description arky [:arky] 2011-07-01 07:47:45 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

cfx commands fail on Mac OSX 10.5 with ... 

$ cfx testall
Testing cfx...
..................................................................................................................
----------------------------------------------------------------------
Ran 114 tests in 5.104s

OK
Testing all examples...
Testing annotator...
Using binary at '/Applications/Firefox.app/Contents/MacOS/firefox-bin'.
dyld: unknown required load command 0x80000022
Traceback (most recent call last):
  File "/Users/arky/src/addon-sdk/bin/cfx", line 29, in <module>
    cuddlefish.run()
  File "/Users/arky/src/addon-sdk/python-lib/cuddlefish/__init__.py", line 487, in run
    test_all(env_root, defaults=options.__dict__)
  File "/Users/arky/src/addon-sdk/python-lib/cuddlefish/__init__.py", line 311, in test_all
    test_all_examples(env_root, defaults)
  File "/Users/arky/src/addon-sdk/python-lib/cuddlefish/__init__.py", line 355, in test_all_examples
    env_root=env_root)
  File "/Users/arky/src/addon-sdk/python-lib/cuddlefish/__init__.py", line 783, in run
    norun=options.no_run)
  File "/Users/arky/src/addon-sdk/python-lib/cuddlefish/runner.py", line 322, in run_app
    version_output = check_output([runner.binary, "-v"])
  File "/Users/arky/src/addon-sdk/python-lib/cuddlefish/runner.py", line 75, in check_output
    raise CalledProcessError(retcode, cmd, output=output)
cuddlefish.runner.CalledProcessError: Command '['/Applications/Firefox.app/Contents/MacOS/firefox-bin', '-v']' returned non-zero exit status -5

# Firefox fails on Mac's 
/Applications/Firefox.app/Contents/MacOS/firefox-bin -v
dyld: unknown required load command 0x80000022
Trace/BPT trap




Actual results:

Guess we have a find a way to handle mac firefox problems ?

A workaround is mentioned here.. 
http://asqueella.blogspot.com/2010/12/dyld-unknown-required-load-command.html

arch -i386 /Applications/Firefox.app/Contents/MacOS/firefox-bin -v  # works fine
Comment 1 Myk Melez [:myk] [@mykmelez] 2011-07-07 11:37:04 PDT

*** This bug has been marked as a duplicate of bug 669791 ***

Note You need to log in before you can comment on or make changes to this bug.