learningwebgl.com Lesson 5: texImage2D throws NS_ERROR_FAILURE when loaded from local file system

RESOLVED DUPLICATE of bug 444641

Status

()

Core
Canvas: WebGL
RESOLVED DUPLICATE of bug 444641
7 years ago
7 years ago

People

(Reporter: WeirdAl, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 7
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
Steps to reproduce:
(1) Download the lessons from https://github.com/gpjt/webgl-lessons/archives/master .
(2) Extract them.
(3) Load gpjt-webgl-lessons-7130f3b/lesson05/index.html from the local file system.

Expected results:  A rotating cube appears with a "NeHe" logo on it.
Actual results:
Error: uncaught exception: [Exception... "Failure arg 5 [nsIDOMWebGLRenderingContext.texImage2D]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/webgl/gpjt-webgl-lessons-7130f3b/lesson05/index.html :: handleLoadedTexture :: line 126"  data: no]

Note that placing the same files on a localhost XAMPP server made the demo function, when loaded from http://localhost...

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
It's a cross-origin load....
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 444641
You need to log in before you can comment on or make changes to this bug.