Mac crash tiny_malloc_from_free_list | szone_malloc | nsAString_internal::MutatePrep using OS X 10.5

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Usul, Unassigned)

Tracking

({crash})

Trunk
x86
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
This bug was filed from the Socorro interface and is 
report bp-936eb9b9-7b6f-4f60-a5ec-987b52110702 .
============================================================= 
0 	libSystem.B.dylib 	tiny_malloc_from_free_list 	
1 	libSystem.B.dylib 	szone_malloc 	
2 	libSystem.B.dylib 	malloc_zone_malloc 	
3 	libSystem.B.dylib 	malloc 	
4 	XUL 	nsAString_internal::MutatePrep 	nsSubstring.cpp:209
5 	XUL 	nsAString_internal::ReplacePrepInternal 	nsTSubstring.cpp:198
6 	XUL 	nsAString_internal::Assign 	
7 	XUL 	nsAString_internal::EnsureMutable 	nsTSubstring.cpp:294
8 	XUL 	AppendASCIItoUTF16 	
9 	XUL 	nsIMAPHostSessionList::GetOnlineDirForHost 	nsIMAPHostSessionList.cpp:259
10 	XUL 	nsImapUrl::AddOnlineDirectoryIfNecessary 	nsImapUrl.cpp:776
11 	XUL 	nsImapUrl::AllocateServerPath 	nsImapUrl.cpp:867
12 	XUL 	nsImapUrl::CreateServerSourceFolderPathString 	nsImapUrl.cpp:1044
13 	XUL 	nsImapProtocol::CanHandleUrl 	nsImapProtocol.cpp:2313
14 	XUL 	nsImapIncomingServer::GetImapConnection 	nsImapIncomingServer.cpp:737
15 	XUL 	nsImapIncomingServer::GetImapConnectionAndLoadUrl 	nsImapIncomingServer.cpp:425
16 	XUL 	nsImapService::GetImapConnectionAndLoadUrl 	nsImapService.cpp:2202
17 	XUL 	nsImapService::FolderCommand 	nsImapService.cpp:1480
18 	XUL 	nsImapService::UpdateFolderStatus 	nsImapService.cpp:1533
19 	XUL 	nsImapMailFolder::UpdateStatus 	nsImapMailFolder.cpp:1446
20 	XUL 	nsImapIncomingServer::GetNewMessagesForNonInboxFolders 	nsImapIncomingServer.cpp:3073
21 	XUL 	nsImapMailFolder::GetNewMessages 	nsImapMailFolder.cpp:2633
22 	XUL 	nsImapIncomingServer::PerformBiff 	nsImapIncomingServer.cpp:1002
23 	XUL 	nsMsgBiffManager::PerformBiff 	nsMsgBiffManager.cpp:381
24 	XUL 	nsTimerImpl::Fire 	nsTimerImpl.cpp:424
25 	XUL 	nsTimerEvent::Run 	nsTimerImpl.cpp:520
26 	XUL 	nsThread::ProcessNextEvent 	nsThread.cpp:618
27 	XUL 	NS_ProcessPendingEvents_P 	nsThreadUtils.cpp:195
28 	XUL 	nsBaseAppShell::NativeEventCallback 	nsBaseAppShell.cpp:130
29 	XUL 	nsAppShell::ProcessGeckoEvents 	nsAppShell.mm:422
30 	CoreFoundation 	CFRunLoopRunSpecific 	
31 	CoreFoundation 	CFRunLoopRunInMode 	
32 	HIToolbox 	RunCurrentEventLoopInMode 	
33 	HIToolbox 	ReceiveNextEventCommon 	
34 	HIToolbox 	BlockUntilNextEventMatchingListInMode 	
35 	AppKit 	_DPSNextEvent 	
36 	AppKit 	-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] 	
37 	AppKit 	-[NSApplication run] 	
38 	XUL 	nsAppShell::Run 	nsAppShell.mm:769
39 	XUL 	nsAppStartup::Run 	nsAppStartup.cpp:222
40 	XUL 	XRE_main 	nsAppRunner.cpp:3686
41 	thunderbird-bin 	main 	nsMailApp.cpp:104
42 	thunderbird-bin 	thunderbird-bin@0xc75


STR none , as Thunderbird was just running in the background.
No idea where to file that so will stay in general for now.
This stack shows up in Firefox crash data as well, only on 10.5.  https://crash-stats.mozilla.com/report/list?signature=tiny_malloc_from_free_list%20|%20szone_malloc

Comment 2

7 years ago
#2 crash for Macs

indeed, all the thunderbird crashes are OS X 10.5, and a high percentage are startup.  like Bug 593132 - Mac crash sorting on subject or on startup
Summary: crash tiny_malloc_from_free_list → crash tiny_malloc_from_free_list | uprv_uca_getRawFromImplicit | ucol_setVariableTop | ucol_getSortKey | UCGetCollationKey

Updated

7 years ago
Summary: crash tiny_malloc_from_free_list | uprv_uca_getRawFromImplicit | ucol_setVariableTop | ucol_getSortKey | UCGetCollationKey → crash tiny_malloc_from_free_list | uprv_uca_getRawFromImplicit | ucol_setVariableTop | ucol_getSortKey | UCGetCollationKey using OS X 10.5

Comment 3

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #2)
> #2 crash for Macs
> 
> indeed, all the thunderbird crashes are OS X 10.5, and a high percentage are
> startup.  like Bug 593132 - Mac crash sorting on subject or on startup

I'm doubt all the crashes are of the same problem. For example not all of the thunderbird crashes involve ucol_getSortKey / UCGetCollationKey.  UCGetCollationKey.  But bug 759798 does.
Crash Signature: [@ tiny_malloc_from_free_list | szone_malloc] → [@ tiny_malloc_from_free_list | szone_malloc] [
Summary: crash tiny_malloc_from_free_list | uprv_uca_getRawFromImplicit | ucol_setVariableTop | ucol_getSortKey | UCGetCollationKey using OS X 10.5 → Mac crash tiny_malloc_from_free_list | uprv_uca_getRawFromImplicit | ucol_setVariableTop | ucol_getSortKey | UCGetCollationKey using OS X 10.5

Comment 4

6 years ago
ludo, Marcia, 

did either of you put UCGetCollationKey in the bug summary? 
It's not in the stack of comment 0
Crash Signature: [@ tiny_malloc_from_free_list | szone_malloc] [ → [@ tiny_malloc_from_free_list | szone_malloc]
(Reporter)

Comment 5

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #4)
> ludo, Marcia, 
> 
> did either of you put UCGetCollationKey in the bug summary? 
> It's not in the stack of comment 0

I don't Think I did, but the bug history doesn't say anything

Comment 6

6 years ago
this is not bug 593132, though the cause may be the same
There are no crashes with this signature in Thunderbird version 17 - Mac 10.5.x is not supported :) https://www.mozilla.org/en-US/thunderbird/17.0/releasenotes/
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Summary: Mac crash tiny_malloc_from_free_list | uprv_uca_getRawFromImplicit | ucol_setVariableTop | ucol_getSortKey | UCGetCollationKey using OS X 10.5 → Mac crash tiny_malloc_from_free_list | szone_malloc | nsAString_internal::MutatePrep using OS X 10.5
You need to log in before you can comment on or make changes to this bug.