mutiple pages crash firefox 5

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Didier Link, Unassigned)

Tracking

({crash})

5 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
Navigating on some pages crashe instantly firefox with this output on terminal :

pure virtual method called
terminate called without an active exception
Aborted

Even in safe-mode. The carshes are more frequent with greasemonkey activated tough. The same situation with 64 bits native version (I'm on Gentoo) or 32 bits binary. Two crash ID sent with the 32bits version :

bp-c3d2c907-f162-47f1-b395-80fd42110626
bp-f18876bc-94cd-446c-9e31-327822110702

I'm back to firefox 4.0.1 for navigating normally (perfect, rock solid since pre 3.0 version).

Thanks to investigate and good luck !

Comment 1

7 years ago
0 	libc-2.13.so 	libc-2.13.so@0x32495 	
1 	libc-2.13.so 	libc-2.13.so@0x33739 	
2 	ld-2.13.so 	ld-2.13.so@0x587 	
3 	libc-2.13.so 	libc-2.13.so@0x6baf 	
4 	libm-2.13.so 	libm-2.13.so@0x281fff 	
5 	ld-2.13.so 	ld-2.13.so@0xcdba 	
6 	libstdc++.so.6.0.14 	libstdc++.so.6.0.14@0xbd8ac 	
7 	libpthread-2.13.so 	libpthread-2.13.so@0xe3fc 	
8 	libstdc++.so.6.0.14 	libstdc++.so.6.0.14@0xbbb75 	
9 	libstdc++.so.6.0.14 	libstdc++.so.6.0.14@0xbbba2 	
10 	libstdc++.so.6.0.14 	libstdc++.so.6.0.14@0xbc4be 	
11 	libxul.so 	js::JSProxyHandler::get 	js/src/jsproxy.cpp:118
12 	libxul.so 	js::proxy_GetProperty 	js/src/jsproxy.cpp:804
13 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:4150
14 	libxul.so 	js::Execute 	js/src/jsinterp.cpp:1006
15 	libxul.so 	EvaluateUCScriptForPrincipalsCommon 	js/src/jsapi.cpp:5039
16 	libxul.so 	JS_EvaluateUCScriptForPrincipalsVersion 	js/src/jsapi.cpp:5055
17 	libxul.so 	nsJSContext::EvaluateString 	dom/base/nsJSEnvironment.cpp:1458
18 	libxul.so 	nsScriptLoader::EvaluateScript 	content/base/src/nsScriptLoader.cpp:906
19 	libxul.so 	nsScriptLoader::ProcessRequest 	content/base/src/nsScriptLoader.cpp:799
20 	libxul.so 	nsScriptLoader::ProcessPendingRequests 	content/base/src/nsScriptLoader.cpp:949
21 	libxul.so 	nsScriptLoader::OnStreamComplete 	content/base/src/nsScriptLoader.cpp:1183
22 	libxul.so 	nsStreamLoader::OnStopRequest 	netwerk/base/src/nsStreamLoader.cpp:125
23 	libxul.so 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_x86_64_unix.cpp:195
24 	libxul.so 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:3139
25 	libxul.so 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1610
26 	libxul.so 	js::Interpret 	js/src/jscntxtinlines.h:698
27 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:726
28 	libxul.so 	js::ExternalInvoke 	js/src/jsinterp.cpp:849
29 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5153
30 	libxul.so 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1667
31 	libxul.so 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:586
32 	libxul.so 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/unix/xptcstubs_x86_64_linux.cpp:153
33 	libxul.so 	libxul.so@0x1058a86 	
34 	libxul.so 	nsHttpChannel::OnStopRequest 	netwerk/protocol/http/nsHttpChannel.cpp:4116
35 	libxul.so 	nsInputStreamPump::OnStateStop 	netwerk/base/src/nsInputStreamPump.cpp:578
36 	libxul.so 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:403
37 	libxul.so 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:114
38 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:618
39 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:250
40 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
41 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:202
42 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
43 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:218
44 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3754
45 	firefox-bin 	main 	browser/app/nsBrowserApp.cpp:158
46 	libc-2.13.so 	libc-2.13.so@0x1eebc 	
47 	firefox-bin 	Output 	browser/app/nsBrowserApp.cpp:77
48 		@0x7fffc7fa280a
Crash Signature: [@ libc-2.13.so@0x32495 ]
Keywords: crash

Comment 2

7 years ago
0 	libc-2.13.so 	libc-2.13.so@0x32495 	
1 	libc-2.13.so 	libc-2.13.so@0x33739 	
2 	ld-2.13.so 	ld-2.13.so@0x587 	
3 	libc-2.13.so 	libc-2.13.so@0x6baf 	
4 	libm-2.13.so 	libm-2.13.so@0x281fff 	
5 	ld-2.13.so 	ld-2.13.so@0xcdba 	
6 	libstdc++.so.6.0.14 	libstdc++.so.6.0.14@0xbd8ac 	
7 	libpthread-2.13.so 	libpthread-2.13.so@0xe3fc 	
8 	libstdc++.so.6.0.14 	libstdc++.so.6.0.14@0xbbb75 	
9 	libstdc++.so.6.0.14 	libstdc++.so.6.0.14@0xbbba2 	
10 	libstdc++.so.6.0.14 	libstdc++.so.6.0.14@0xbc4be 	
11 	libxul.so 	js::JSProxyHandler::get 	js/src/jsproxy.cpp:118
12 	libxul.so 	js::proxy_GetProperty 	js/src/jsproxy.cpp:804
13 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:4150
14 	libxul.so 	js::Execute 	js/src/jsinterp.cpp:1006
15 	libxul.so 	EvaluateUCScriptForPrincipalsCommon 	js/src/jsapi.cpp:5039
16 	libxul.so 	JS_EvaluateUCScriptForPrincipals 	js/src/jsapi.cpp:5066
17 	libxul.so 	xpc_EvalInSandbox 	js/src/xpconnect/src/xpccomponents.cpp:3685
18 	libxul.so 	nsXPCComponents_Utils::EvalInSandbox 	js/src/xpconnect/src/xpccomponents.cpp:3575
19 	libxul.so 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_x86_64_unix.cpp:195
20 	libxul.so 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:3139
21 	libxul.so 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1610
22 	libxul.so 	js::Interpret 	js/src/jscntxtinlines.h:698
23 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:726
24 	libxul.so 	js::ExternalInvoke 	js/src/jsinterp.cpp:849
25 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5153
26 	libxul.so 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1667
27 	libxul.so 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:586
28 	libxul.so 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/unix/xptcstubs_x86_64_linux.cpp:153
29 	libxul.so 	libxul.so@0x1058a86 	
30 	libxul.so 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1136
31 	libxul.so 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:1231
32 	libxul.so 	nsEventTargetChainItem::HandleEvent 	content/events/src/nsEventListenerManager.h:146
33 	libxul.so 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:312
34 	libxul.so 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:646
35 	libxul.so 	nsEventDispatcher::DispatchDOMEvent 	content/events/src/nsEventDispatcher.cpp:709
36 	libxul.so 	nsDocument::DispatchEvent 	content/base/src/nsDocument.cpp:6318
37 	libxul.so 	nsContentUtils::DispatchTrustedEvent 	content/base/src/nsContentUtils.cpp:3415
38 	libxul.so 	nsDocument::DispatchContentLoadedEvents 	content/base/src/nsDocument.cpp:4171
39 	libxul.so 	nsRunnableMethodImpl<void , true>::Run 	nsThreadUtils.h:345
40 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:618
41 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:250
42 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
43 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:202
44 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
45 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:218
46 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3754
47 	firefox-bin 	main 	browser/app/nsBrowserApp.cpp:158
48 	libc-2.13.so 	libc-2.13.so@0x1eebc 	
49 	firefox-bin 	Output 	browser/app/nsBrowserApp.cpp:77
50 		@0x7fffe35d21da

Comment 3

7 years ago
Mozilla/5.0 (X11; Linux i686; rv:8.0a1) Gecko/20110711 Firefox/8.0a1

Can you please provide a list with some of the web-pages that are producing the crash on your system?

Also, try it on a clean, new profile just to rule out a bad profile:
http://support.mozilla.com/en-US/kb/Managing-profiles
(Reporter)

Comment 4

7 years ago
Hi, thanks for your interest !

The pages was really numerous, I think of http://www.ogame.fr, the mozilla bugzilla too, very annoying. BUT since the report I navigated with firefox 4 for not switch to another browser and with your request I reinstall firefox 5 and now it work like a charm !!! :/

I can't find any page crash at all since yesterday !

I think it was a bug in another library, notably the glibc and xorg-server was updated on my system since bug report ... I can't confirm this, it's just my opinion ;)

Anyway, thanks again for try to solve this issue with me !

Comment 5

7 years ago
OK Didier, glad to hear that! I'll close the bug until further, but feel free to reopen if the problems reoccur.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.