Last Comment Bug 669015 - nsTextBoxFrame shadows aren't rendered anymore
: nsTextBoxFrame shadows aren't rendered anymore
Status: RESOLVED FIXED
[qa-]
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- major with 1 vote (vote)
: mozilla7
Assigned To: Michael Ventnor
:
Mentors:
: 669038 669183 (view as bug list)
Depends on:
Blocks: 666689
  Show dependency treegraph
 
Reported: 2011-07-02 13:53 PDT by Dão Gottwald [:dao]
Modified: 2011-09-22 15:47 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
sample xul (739 bytes, application/vnd.mozilla.xul+xml)
2011-07-02 22:47 PDT, Alice0775 White
no flags Details
Patch (4.15 KB, patch)
2011-07-03 04:26 PDT, Michael Ventnor
roc: review+
Details | Diff | Review

Description Dão Gottwald [:dao] 2011-07-02 13:53:00 PDT

    
Comment 1 Michael Ventnor 2011-07-02 17:56:00 PDT
Do you have a testcase?

The reftests are passing and I know they test this.
Comment 2 Michael Ventnor 2011-07-02 22:16:37 PDT
*** Bug 669038 has been marked as a duplicate of this bug. ***
Comment 3 Alice0775 White 2011-07-02 22:47:03 PDT
Created attachment 543655 [details]
sample xul
Comment 4 Michael Ventnor 2011-07-03 04:26:25 PDT
Created attachment 543669 [details] [diff] [review]
Patch

I also did some renaming to make function names consistent between this and the overflow marker code.
Comment 5 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-07-03 20:32:09 PDT
Comment on attachment 543669 [details] [diff] [review]
Patch

Review of attachment 543669 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 7 Marco Bonardo [::mak] 2011-07-04 05:08:59 PDT
http://hg.mozilla.org/mozilla-central/rev/817c3b2e2fbb
Comment 8 j.j. 2011-07-04 11:03:11 PDT
*** Bug 669183 has been marked as a duplicate of this bug. ***
Comment 9 Virgil Dicu [:virgil] [QA] 2011-08-19 06:49:43 PDT
Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20100101 Firefox/7.0

Could you provide some clear steps to reproduce in order to verify this issue on QA side?
Comment 10 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-09-22 15:47:30 PDT
qa- as no QA verification is needed

Note You need to log in before you can comment on or make changes to this bug.