Last Comment Bug 669025 - "ASSERTION: Class name and proto chain interface name mismatch!"
: "ASSERTION: Class name and proto chain interface name mismatch!"
Status: RESOLVED FIXED
: assertion, regression, testcase
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: mozilla7
Assigned To: Robert Longson
:
Mentors:
Depends on:
Blocks: 326633 617623
  Show dependency treegraph
 
Reported: 2011-07-02 18:26 PDT by Jesse Ruderman
Modified: 2011-07-04 05:12 PDT (History)
6 users (show)
longsonr: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (191 bytes, image/svg+xml)
2011-07-02 18:26 PDT, Jesse Ruderman
no flags Details
stack trace (1.76 KB, text/plain)
2011-07-02 18:27 PDT, Jesse Ruderman
no flags Details
patch (1.87 KB, patch)
2011-07-03 02:55 PDT, Robert Longson
dholbert: review+
Details | Diff | Splinter Review
hg changeset patch with tests (2.56 KB, patch)
2011-07-03 12:51 PDT, Robert Longson
no flags Details | Diff | Splinter Review
fix typo (2.56 KB, patch)
2011-07-03 14:13 PDT, Robert Longson
no flags Details | Diff | Splinter Review

Description Jesse Ruderman 2011-07-02 18:26:48 PDT
Created attachment 543640 [details]
testcase

###!!! ASSERTION: Class name and proto chain interface name mismatch!: 'nsCRT::strcmp(CutPrefix(name), mData->mName) == 0', file /builds/slave/m-cen-osx64-dbg/build/dom/base/nsDOMClassInfo.cpp, line 4930

The first bad revision is:
changeset:   6ef387126d0f
user:        Robert Longson
date:        Fri Jul 01 08:19:52 2011 +0100
summary:     Bug 617623 - animate number-optional-number and integer-optional-integer attributes properly. r=dholbert
Comment 1 Jesse Ruderman 2011-07-02 18:27:20 PDT
Created attachment 543641 [details]
stack trace
Comment 2 Robert Longson 2011-07-03 02:55:52 PDT
Created attachment 543662 [details] [diff] [review]
patch
Comment 3 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2011-07-03 12:18:40 PDT
Comment on attachment 543662 [details] [diff] [review]
patch

Could you include crashtests for both changes? (both the Integer & Number varieties)
Comment 4 Robert Longson 2011-07-03 12:51:05 PDT
Created attachment 543692 [details] [diff] [review]
hg changeset patch with tests
Comment 5 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2011-07-03 14:10:50 PDT
Ms2ger pushed this to m-i, but it caused orange due to typo in crashtest.list manifest.

It needs s/669205/669025/

I don't have a local m-i repo or I'd fix it.  I'll try to get one over my current veryslow internet connection, but if anyone else can fix it before I do, please do.
Comment 6 Robert Longson 2011-07-03 14:13:10 PDT
Created attachment 543699 [details] [diff] [review]
fix typo
Comment 7 Phil Ringnalda (:philor, back in August) 2011-07-03 14:22:06 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/58b34369196f
Comment 8 Robert Longson 2011-07-03 15:01:28 PDT
Thanks Phil. Kind of you.

Note You need to log in before you can comment on or make changes to this bug.