Closed Bug 669031 Opened 8 years ago Closed 8 years ago

Frequent LINK : fatal error LNK1266: error reading instrumentation file 'vmwarerecordinghelper.pgd'; File not found

Categories

(Firefox Build System :: General, defect)

x86
Windows Server 2003
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 679334

People

(Reporter: philor, Assigned: glandium)

References

Details

(Keywords: intermittent-failure, Whiteboard: [red])

Attachments

(1 file)

Because that's the way we roll, we've just been retriggering these, with or without a vague handwaving comment.

http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1309643728.1309646864.27173.gz
WINNT 5.2 mozilla-inbound build on 2011/07/02 14:55:28
s: mw32-ix-slave02

crashinject.obj 
LINK : fatal error LNK1266: error reading instrumentation file 'crashinject.pgd'; File not found


tinderbox.mozilla.org/showlog.cgi?log=Jaegermonkey/1309658022.1309661509.13509.gz
WINNT 5.2 jaegermonkey build on 2011/07/02 18:53:42
s: mw32-ix-slave05

crashinject.obj 
LINK : fatal error LNK1266: error reading instrumentation file 'crashinject.pgd'; File not found
http://tinderbox.mozilla.org/showlog.cgi?log=Jaegermonkey/1309662371.1309664468.24307.gz
WINNT 5.2 jaegermonkey build on 2011/07/02 20:06:11
s: mw32-ix-slave03

crashinject.obj 
LINK : fatal error LNK1266: error reading instrumentation file 'crashinject.pgd'; File not found
http://tinderbox.mozilla.org/showlog.cgi?log=Jaegermonkey/1313038974.1313039904.13737.gz (sort of vague interesting, since the same slave picked up my retrigger from comment 15 and failed again, which I don't think I've seen before)
And http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313040902.1313041866.22644.gz is three times on one slave on one push - I must not have been retriggering this before.
Attached patch WallpaperSplinter Review
No idea what's going on, but this should wallpaper over it.
Attachment #553151 - Flags: review?(ted.mielczarek)
Comment on attachment 553151 [details] [diff] [review]
Wallpaper

Review of attachment 553151 [details] [diff] [review]:
-----------------------------------------------------------------

::: build/win32/Makefile.in
@@ +41,5 @@
>  VPATH = @srcdir@
>  
>  include $(DEPTH)/config/autoconf.mk
>  
> +NO_PROFILE_GUIDED_OPTIMIZE = 1

I am crossing my fingers, but my guess is that this will manifest as the same error in a different directory. (I bet this is just the first thing that gets linked with PGO. And yes, I know this patch was my idea.)
Attachment #553151 - Flags: review?(ted.mielczarek) → review+
Always good to get that quick confirmation:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1313417133.1313420753.20552.gz
LINK : fatal error LNK1266: error reading instrumentation file 'vmwarerecordinghelper.pgd'; File not found
Summary: Frequent LINK : fatal error LNK1266: error reading instrumentation file 'crashinject.pgd'; File not found → Frequent LINK : fatal error LNK1266: error reading instrumentation file 'vmwarerecordinghelper.pgd'; File not found
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1313433316.1313434243.3301.gz

But at least it was only two out of three builds on your push (since the third one died in the network hiccup).
I think bug 659942 is to blame here. That patch added a step to rm the .pgd file in the export step of the MOZ_PROFILE_GENERATE half of the build. However, if we don't wind up re-linking the binary, that means we don't have a .pgd file, and things will break.
Assignee: nobody → mh+mozilla
Alternately we could try pgomgr /clear instead of rm:
http://msdn.microsoft.com/en-us/library/2kw46d8w%28v=vs.80%29.aspx
"/clear—Causes the .pgd file to be cleared of all profile information. You cannot specify a .pgc file when /clear is specified."
https://tbpl.mozilla.org/php/getParsedLog.php?id=6213856

LINK : fatal error LNK1266: error reading instrumentation file 'libGLESv2.pgd'; File not found
(In reply to Phil Ringnalda (:philor) from comment #31)
> https://tbpl.mozilla.org/php/getParsedLog.php?id=6213856
> 
> LINK : fatal error LNK1266: error reading instrumentation file
> 'libGLESv2.pgd'; File not found

This is on m-i, before any merge of bug 679334, which really is the same thing. I'm relieved :)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 679334
Whiteboard: [orange][red] → [red]
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.