Tagged mails displayed as normal with Enigmail installed (Aero only)

RESOLVED INVALID

Status

Thunderbird
Theme
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Patrick Brunschwig, Unassigned)

Tracking

x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
Created attachment 543666 [details]
Screenshot

If Enigmail is installed then selected tagged mails are only visible in color if the mail is not selected (see attached screenshot). This happens only on Windows with Aero, all other platforms are OK.

I'm not claiming that this is a bug in Thunderbird, but I have no idea what to fix because Enigmail doesn't style the tree. I should add that Enigmail adds a custom column. Any hints appreciated.
(Reporter)

Comment 1

7 years ago
Created attachment 543667 [details]
Enigmail's chrome.manifest
(Reporter)

Comment 2

7 years ago
Created attachment 543668 [details]
CSS file for Windows with Aero
With removing of @import url("chrome://messenger/skin/"); on line 40 the highlighting works again.

I haven't checked if removing of this has side-effects, but a quick check showed no problems.
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> I haven't checked if removing of this has side-effects, but a quick check
> showed no problems.

This does have side effects. They are maybe not immediately visible, but I didn't add the line without having good reasons.
Component: Mail Window Front End → Theme
QA Contact: front-end → theme
Richard can you try to fix this ?
I don't think I can fix this. I'm not using Enigmail and can't say what is causing by removing the import line. I have also no development system which can analyze treechildren. I'm using only DOMi and this can not show the tree structure.

Enigmail is also an Add-on (I know an important one). Without Enigmail the highlighting works well, so the problem isn't on TB's side. I helped to point to the problem, but the Add-on author should solve this because he knows his work better the I can.
(Reporter)

Comment 7

7 years ago
Thanks Robert, I think I found a way fix this without needing to touch all XUL files. 

Setting to invalid as this is not a Thunderbird bug.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.