Closed Bug 66919 (toolbar-overflow) Opened 20 years ago Closed 18 years ago

Toolbar overflow handling (e.g. for Personal Toolbar bookmarks)

Categories

(Core :: XUL, enhancement, P3)

enhancement

Tracking

()

VERIFIED FIXED
mozilla1.4alpha

People

(Reporter: jkng, Assigned: jag+mozilla)

References

Details

(Keywords: helpwanted, Whiteboard: [adt2])

Attachments

(4 files, 1 obsolete file)

From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Win98; U)
BuildID:    2001012504 

It would be a nice enhancement to have something equivalent to the double arrow 
drop down-menu that IE uses to display bookmarks/folders in the cut off personal 
toolbar when the browser window is resized down (to the point when your 
bookmarks start disappearing from the personal toolbar). 

Reproducible: Always
Steps to Reproduce:
resize browser until bookmarks/folders on the right of the personal toolbar are 
no longer visible.

Actual Results:  bookmarks/folders not visible on personal toolbar when sized 
down

Expected Results:  would like to have a drop-down list or something similar to 
access the concealed bookmarks
Good idea
Confirming and modifying the summary to be a little clearer
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Hardware: PC → All
Summary: not all bookmarks/folders visible in personal toolbar when resized down → [rfe]dropdown list of bookmark in the personal toolbar when there is not enough place for all of them
An alternative would be to make the personal toolbar taller when it contains 
many items (bug 12759).
From a usability perspective I like IE's 'left-overs' menu best, as the solution
with having a taller toolbar (ie 2 'lines')leaves of lots of unsightly
situations where items of different lengths do not line up. As a result n-line
toolbar items will be much harder to find and parse.
While we are brainstorming, here are some other crazy ideas:
- add scroll buttons to either side in case of overflow
- add autoscroll zones on either side like in menus, the toolbar would scroll
back after having selected an item
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla0.9.7
*** Bug 103543 has been marked as a duplicate of this bug. ***
Blocks: 102472
bug 103543 I filed is about 1 side-scrolling button on the left and right side
of a toolbar not bookmarks, but the toolbars itself or in this cause similar but
not equal to autoscrolling.. 
Most of the overflow solutions seem to lose the primary benefit of the toolbar -
one-click access.  I'd like to provide toolbars that expand to multiple rows for
user-expandable cases like this (though I doubt I'd use them myself), because:
* It is a simple, understandable, predictable expansion of the toolbar.
* It preserves the one-click access.
* You can still see all the contents of the toolbar.
* They are familiar to  people, due to being in Windows desktop toolbars.
* I imagine that the folks who make their toolbars unsightly just won't show
them to German. ;-)

Of course, multiple solutions for this already appear in Windows toolbars, and
coexist nicely.
ah, yes, much like the windows toobar that is expandable to two or more rows, 
would probably be somewhat of a rework, that includes the toolbar header coding
for moving stuff around like standard windows app toolbar areas.. as well as
resizing toolbars with 'grippies'

and how about the new XP feature that uses bubbling same apps (or in this case
same sites links) would most probably be the best type of implemenations.. I
vote this enhancement over  the other three I know have been suggested,

We should change this to a tracking bug just for Toolbar overflow bug
enhancement Ideas

Peter,

are there bugs for these types of solutions already?
It should be easy to create a general toolbar add-on that would allow
modifications  to any method of overflow enhancement.

Just like the bug that tracks link toolbar improvements at 103053, that is all
for today.
Navteam is using this bug to track planning, design and implementation of this
feature in our MachV project. Let's discuss the ideas in the appropriate
newsgroup, then just add links here as appropriate. I'm not aware of other bugs
on this, but it would be good to reference them here too.
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW
Joe has volunteered to take this. 
Assignee: pchen → hewitt
Status: NEW → ASSIGNED
Summary: [rfe]dropdown list of bookmark in the personal toolbar when there is not enough place for all of them → personal toolbar overflow handling
*** Bug 106319 has been marked as a duplicate of this bug. ***
Target Milestone: mozilla0.9.7 → mozilla0.9.9
*** Bug 114483 has been marked as a duplicate of this bug. ***
*** Bug 114688 has been marked as a duplicate of this bug. ***
already dropped this from MachV, ->moz1.0.1/helpwanted.
Keywords: helpwanted
Target Milestone: mozilla0.9.9 → mozilla1.0.1
I cast my vote with Comment #6

This is what OmniWeb does, and it works great. Not only does it maintain
one-click access, but it provides a disincentive to let your toolbar bookmarks
list get out of hand... since you can see them all, and they take up space, you
actively maintain the list to place only the very useful ones there.

-matt
This targetted for M101. Should we remove it from blocking Bug 102472, since its
current target is outside the dev window for the next release?
Sure, removing.
No longer blocks: 102472
*** Bug 127721 has been marked as a duplicate of this bug. ***
*** Bug 128770 has been marked as a duplicate of this bug. ***
adding self to cc list
*** Bug 141048 has been marked as a duplicate of this bug. ***
*** Bug 143799 has been marked as a duplicate of this bug. ***
*** Bug 145535 has been marked as a duplicate of this bug. ***
*** Bug 146833 has been marked as a duplicate of this bug. ***
I suggest only expanding the toolbar when the user hovers on it.
*** Bug 149735 has been marked as a duplicate of this bug. ***
I like both ideas (left-overs in #c3 and multi-row in #c6).
But since I don't think throwing in so much bookmarks they don't fit onto the
line is wanted by the user I'd prefer left-overs. It happens for a short time
while you need to access much bookmarks or resize the window down - in this
cases the one-click-access is not a must have, but to save room is.
My vote is with #3, not #6. I find that the way that it is handled on IE works
well, in that I already do sort the links that matter most to me, even within
the Personal Toolbar. I drag the most important links to the front of the
Personal Toolbar so that they are visible, where the other ones require one
additional (yet easy and uncluttered) click to get to. I don't think multiple
lines of bookmarks is a "feature"... I'd see it as a disincentive to use the
browser, myself.

This is a really big usability feature for me. Like many others out there, I use
a lot of bookmarklets for all sorts of tasks. (Posting to weblogs, searching,
dictionary, webpage translation, web design, etc.) I keep them all in my
Personal Toolbar for immediate access. My actual bookmark folder is *HUGE* and
far less usable, in comparison.
> They are familiar to  people, due to being in Windows desktop toolbars.

Windows desktop toolbars don't expand to multiple rows on overflow. They receive
chevrons, the same way as reported in comment 0 of this bug, and the way
proposed in mpt's Navigator chrome overview spec.

I've filed bug 153601 about overflow handling of toolbars just before mpt
indirectly pointed me to this bug. I don't really see them as dups though.
This be a general toolbar bug, not a Personal Toolbar bug in particular. When 
it is implemented, the Toolbar and (in Windows or X) the menu bar should get it 
automatically, as well as the Personal Toolbar. --> XP Toolkit/Widgets
Component: Bookmarks → XP Toolkit/Widgets
Summary: personal toolbar overflow handling → Toolbar overflow handling (e.g. for Personal Toolbar bookmarks)
*** Bug 154175 has been marked as a duplicate of this bug. ***
*** Bug 155964 has been marked as a duplicate of this bug. ***
aliasing this bug as toolbar-overflow
Alias: toolbar-overflow
*** Bug 156350 has been marked as a duplicate of this bug. ***
*** Bug 111650 has been marked as a duplicate of this bug. ***
*** Bug 162103 has been marked as a duplicate of this bug. ***
*** Bug 166265 has been marked as a duplicate of this bug. ***
Rather that waiting for a general mechanism to allow toolbars to expand to
multiple rows, it would be helpul to just have a "More..." button to popup the
very same menu that is presently hidden in Bookmarks -> Personal Toolbar Folder.

In my current copy of Netscape 7, the purpose of the toolbar is simply defeated
given that the space is filled up by the factory pre-built entries that come
with Netscape 7. As initially suggested in the opening comments, just having a
"More..." button to activate the drop down list would help a lot, while awaiting
other sophisticated solutions that might take a while to materialize.
Keywords: nsbeta1
Interesting thing to note, the Chimera build 2002090913 has bookmark handling just like 
Omniweb in the toolbar.   Now why build 2002101612 of Mozilla doesn't have it makes 
me wonder...was there something unstable about the code for the Chimera toolbar that 
made it be pulled out?  I find the Java support is getting more improved Mozilla yet not 
perfect, but still now I find I like to use Mozilla more than Chimera because of better 
website support.   If we can get Chimera's toolbar in Mozilla that would be great!

Thank you.
Re: Comment #41 From abrody@smart.net  2002-10-23 15:19

> Interesting thing to note, the Chimera build 2002090913 has bookmark handling
> just like Omniweb in the toolbar.

They share the same front-end toolkit (Aqua/Cocoa).

> Now why build 2002101612 of Mozilla doesn't have it makes
> me wonder...

Because Mozilla does not, did never, and most likely will never use native
front-ends, but instead uses its own toolkit based on XUL / XPFE / ... AND
XP-something do not have Apple's toolbar features. Although Phoenix has a
rip-off of them.

> was there something unstable about the code for the Chimera toolbar that
> made it be pulled out?

It wasn't pulled out as it was never put in in the first place. Chimera is a
different product, y'know. Only the back-ends are mostly the same.

> I find the Java support is getting more improved Mozilla yet not
> perfect, but still now I find I like to use Mozilla more than Chimera because
> of better website support.

Chimera uses Mozilla 1.0.1's backend. That's the only reason why Chimera
supports less sites. Once Chimera is upgraded to a newer Mozilla codebase, that
won't be an issue for a while.

> If we can get Chimera's toolbar in Mozilla that would be great!

Not going to happen.

NB: This is not an end-user forum.
any chance the toolbar overflow handling code from phoenix will be ported over
to moz in the near future?
nsbeta1+/adt2 per the nav triage team.

Keywords: nsbeta1nsbeta1+
Whiteboard: [adt2]
*** Bug 187376 has been marked as a duplicate of this bug. ***
*** Bug 188348 has been marked as a duplicate of this bug. ***
*** Bug 187545 has been marked as a duplicate of this bug. ***
XP Toolkit/Widgets can't apply to all operating systems.  And yet this is a bug which applies to all operating systems versions of Mozilla.  Also the target milestone of 1.0.1 is too low.  Version 1.2.1 which was already released surpasses this milestone and it hasn't been fixed yet.
*** Bug 191123 has been marked as a duplicate of this bug. ***
-> jag
Assignee: hewitt → jaggernaut
Status: ASSIGNED → NEW
Phoenix doesn't have generic toolbar overflow handling. They have a specific
implementation for their personal toolbar.
Target Milestone: mozilla1.0.1 → mozilla1.4alpha
*** Bug 194348 has been marked as a duplicate of this bug. ***
*** Bug 195790 has been marked as a duplicate of this bug. ***
If this is implemented, I'd like to see it made available for all mozilla
toolbars, with the aim of having it on custom toolbars as well (for example, the
Googlebar generates find buttons for each search term; long queries go off the
screen, crush the search terms textbox to its minimum size, and still don't
allow buttons to be created for every term- there's not enough room).  The
personal toolbar isn't the only one that would have a use for it.
Comment on attachment 118514 [details] [diff] [review]
Add support for overflow to the personal toolbar bookmarks.

Note: the image used for the chevron can be seen here:
http://lxr.mozilla.org/mozilla/source/toolkit/skin/win/toolbar/chevron.gif
Attachment #118514 - Flags: superreview?(bryner)
Attachment #118514 - Flags: review?(shliang)
Attachment #118514 - Flags: superreview?(bryner) → superreview+
Attachment #118514 - Flags: review?(shliang) → review+
Looked at this on my machine and I don't see an increase in Txul.
comet says no increase in Txul, but 20ms increase in Ts.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
QA Contact: claudius → gbush
using 2003.03.26.08 comm bits on linux rh8.0 and win2k, the dropdown i get from
the overflow chevron is only few pixels big. tested in both modern and classic
themes.

reopening. screenshot coming up.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
another thing i noticed --if there are no user-added items to the PT, or if
there are and you shrink the window so that only the default PT items are
visible, the overflow widget will not appear.
just tested this with a mozilla nightly, and it's not a problem. i'll go and
file the issue i saw in comment 59 in bugscape. reclosing.
Status: REOPENED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → FIXED
The overflow mechanism currently doesn't work for the "bookmarks" we provide in
the personal toolbar. Full (generic) toolbar overflow support should make up for
that.
Attached patch Supplementary patch (obsolete) — Splinter Review
Collapsed menuitems doesn't work properly (don't know why), use hidden instead.
Attachment #118626 - Flags: superreview?(jaggernaut)
Attachment #118626 - Flags: review?(shliang)
With build 2003032708 under XP, the text of a bookmark folder falls over the
arrow to view other bookmarks.

Dragging an address over the arrow doesn't bring up the menu with the hidden
bookmars/bookmark folders in order to drop the new address in there. Should I
create a new entry for this bug/enhancement or does it fall within the
intentions of this bug?
Probably related to this is that you can't drag items on the dropdown to another
location (either on the dropdown, or on the toolbar). You get the visual
feedback (drag cursor and the line to indicate the new location) but when you
drop, nothing happens.
Also, minor nit, the arrow icon could do with being larger to make it more
obvious that there is an overflow.
re: comment 65 (overlapping text)

I noticed the same problem in Phoenix, and created a patch for it in bug 180156.

The relevant code looks similar enough between Moz and Px, I'd bet the code
would fix it in both browsers.
verified in mozilla builds - bug for commercial builds problems is bug 23078
Status: RESOLVED → VERIFIED
Attached patch Fixed patchSplinter Review
Doh, forgot the /g on the end of the %s/menu\.collapsed/menu\.hidden :-[
Attachment #118626 - Attachment is obsolete: true
Hrm, why doesn't |menu.collapsed = true| hide these menuitems? Is something else
going on here, and |menu.hidden = true| just a band-aid?
Without spending too much time actually looking at the code, there appear to be
two issues with using .collapsed:
1. All the margins (usually separators) get tacked onto the bottom of the menu
(this one really confuses me as I did expect them to show, but at the top).
2. The C++ code doesn't seem to check for it so for example if you press the
overflow button you can't navigate properly using the arrow keys.
I found a lame workaround of using menu[collapsed="true"],
menuitem[collapsed="true"], menuseparator[collapsed="true"] { display: none; }
As of 2003033105 (Windows XP) I still see the issue of a tiny box as pictured in
comment 60.

I believe this happens every time after I install the Preferences Toolbar, as
found in http://www.xulplanet.com/downloads/prefbar/

The bookmars also dissapear/don't show when the bookmark button is pressed. I
just see up until the separator after "Manage Bookmarks...   Ctrl+B"
Confirming comment #72 with MultiZilla and this is what I get on the JS console:

Warning: reference to undefined property aMenuPopup.childNodes[i]
Source File: chrome://communicator/content/bookmarks/bookmarksMenu.js
Line: 714

Error: menu has no properties
Source File: chrome://communicator/content/bookmarks/bookmarksMenu.js
Line: 715

The first warning 10 times and the second only one time. I hope this helps but I
wonder if we should file a new bug report because this bug is verified fixed?!
Jose, take a look at bug 66919 comment #41 because that fixed the empty
bookmarks button on the Personal Toolbar for us.
Hmm, seems the overflow doesn't work with uabar installed. I just installed
uabar and, even with the bar hidden, although the overflow button remains
visible, clicking it does nothing.

Uninstalled uabar (by uninstalling Moz and reinstalling) and it works again.

Is this a Moz problem or one for the uabar guys?

Also, the button doesn't appear when Moz is run for the first time after
install; the PTB appears truncated as pre this fix. Hitting F9 twice fixes it.
Since you need to do F9, F9 to get the sidebar to populate this could be related
to/caused by bug 119975 perhaps.
Jose, make that bug comment 41 of bug 101131, sorry for the confusion. 

Note to Parish: no, this has nothing to do with uabar, or any other add-on for
that mather, but mozilla.
This is a very nice feature, that is triggered when you release the button after
resizing. Is it possible to implement it like IE? There the items
disappear/appear when resizing, releasing the mouse button for an update is not
necessary.

Or maybe I should file a new bug? RFE
RE comment #77: The word "dynamic" (in new bug or in comments) may help when
searching for this excellent idea.
FYI: Filed bug 201002 for what i mentioned in comment 77.
*** Bug 201559 has been marked as a duplicate of this bug. ***
Comment on attachment 118809 [details] [diff] [review]
Fixed patch

r+sr=jag
Attachment #118809 - Flags: superreview+
Attachment #118809 - Flags: review+
Attachment #118809 - Flags: approval1.4b?
Comment on attachment 118809 [details] [diff] [review]
Fixed patch

a=sspitzer
Attachment #118809 - Flags: approval1.4b? → approval1.4b+
Attachment #118626 - Flags: superreview?(jaggernaut)
Attachment #118626 - Flags: review?(shliang)
You need to log in before you can comment on or make changes to this bug.