The navigation bar is gone when going to about:permissions

RESOLVED INVALID

Status

()

Firefox
Preferences
--
major
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Frédéric Buclin, Unassigned)

Tracking

6 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(firefox6-)

Details

(Reporter)

Description

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:6.0a2) Gecko/20110704 Firefox/6.0a2

Once I go to about:permissions, the navigation bar is gone, and so I cannot type any new URL in the address bar, or click the Back button. This doesn't happen with other about:* pages.
(Reporter)

Comment 1

7 years ago
Note that this problem doesn't occur if tabs are below the navigation bar. This only occurs when tabs are above it (which is the default value).

Comment 2

7 years ago
This is intentional. Similarly to about:addons, we wanted to make this page look different than normal web pages, so that it's easier for users to understand that this is part of the browser, not part of the web. This is part of a bigger project to make unified styles for in-content pages: https://wiki.mozilla.org/Features/Firefox/In-content_UI_Visual_Unification.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

7 years ago
This is totally confusing when you have no other tab opened. What is the user supposed to do in that case??

Comment 4

7 years ago
You can use File->Open Location or cmd/ctrl+L, or you can can open a new tab.
Hrm - this behaviour is by design, but I agree with comment 3 that if this were your only tab, you'd be a pretty confusing state. Margaret - when this feature is given more visible treatment, is there a plan from UX for how to deal with this confusion? I'm tempted to re-open and morph this bug to be "Hiding navigation UI makes it hard to escape about pages when they're the only open tab" but I don't want to do that if plans already exist in other bugs to address this.
tracking-firefox6: ? → -
(In reply to comment #5)
> Hrm - this behaviour is by design, but I agree with comment 3 that if this
> were your only tab, you'd be a pretty confusing state. Margaret - when this
> feature is given more visible treatment, is there a plan from UX for how to
> deal with this confusion? I'm tempted to re-open and morph this bug to be
> "Hiding navigation UI makes it hard to escape about pages when they're the
> only open tab" but I don't want to do that if plans already exist in other
> bugs to address this.

This has come up before, with the general consensus being to just leave it, I believe.  The reason is that if the user opens one window and goes straight to the add-on manager or about:permissions, it's true that the URL and search bar are gone.  The ways to progress from here are:

1. Click the new tab button
2. Open a new window or tab via keyboard shortcuts
3. Use menu to get new tab or window

The ways you can't progress are:

4. Search bar
5. URL bar

If the user has deliberately opened the add-ons manager or about:permission, they probably are familiar with 1-3.  So the instance when someone is in some trouble is if they accidentally trigger one of these in-content pages... or even accidentally turn their current page into an app tab.

Perhaps to mitigate against this, we should open the in-content page in a new tab if the user has no other tabs.  It doesn't change the confusion someone may feel if they triggered it accidentally, but it does provide an obvious target to get back to the land of normalcy without creating inconsistent behavior for in-content pages.
(In reply to comment #6)

> Perhaps to mitigate against this, we should open the in-content page in a
> new tab if the user has no other tabs.  It doesn't change the confusion
> someone may feel if they triggered it accidentally, but it does provide an
> obvious target to get back to the land of normalcy without creating
> inconsistent behavior for in-content pages.

This is what we do for the AM currently, iinm, and I think it's a good approach (since the number of users typing about:addons is pretty small). If about:permissions is intended to have similar behaviour, I think that will do the trick for most users as well, but I wanted to make sure it was suitably integrated into designs before we start showing more users this feature (or others with similar behaviour)

Comment 8

7 years ago
(In reply to comment #7)
> (In reply to comment #6)
> 
> > Perhaps to mitigate against this, we should open the in-content page in a
> > new tab if the user has no other tabs.  It doesn't change the confusion
> > someone may feel if they triggered it accidentally, but it does provide an
> > obvious target to get back to the land of normalcy without creating
> > inconsistent behavior for in-content pages.
> 
> This is what we do for the AM currently, iinm, and I think it's a good
> approach (since the number of users typing about:addons is pretty small).

I just typed about:addons into a window with no other tabs, and it overwrote my current tab just as about:permissions does. I think we should file a new bug to change this behavior generally for in-content pages if that's the route we want to go.
You need to log in before you can comment on or make changes to this bug.