Closed Bug 669312 Opened 9 years ago Closed 9 years ago

accessible name is duplicated when input has a label associated uisng for/id and is wrapped around the input

Categories

(Core :: Disability Access APIs, defect)

5 Branch
All
Other
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 682790

People

(Reporter: faulkner.steve, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

go to http://www.html5accessibility.com/tests/form-labels.html
use an inspect tool to view the accessible name for inputs in tests 4 and 6


Actual results:

the accessible name consists of the label text repeated


Expected results:

the accessible name consists of the label text
Component: Disability Access → Disability Access APIs
Product: Firefox → Core
QA Contact: disability.access → accessibility-apis
Blocks: namea11y
Status: UNCONFIRMED → NEW
Ever confirmed: true
Interesting! I this actuallz being done in the wild a lot, or is this a corner case, Steve_
(In reply to comment #1)
> Interesting! I this actuallz being done in the wild a lot, or is this a
> corner case, Steve_

I don't have any figures on its use, but its a legitimate method for explcitly associating label text that is located both before and after an input.
marking as dupe of bug 682790 since that bug contains steps to fix.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 682790
You need to log in before you can comment on or make changes to this bug.