Installer checks integrity of non-selected components

VERIFIED INVALID

Status

SeaMonkey
Installer
--
critical
VERIFIED INVALID
17 years ago
13 years ago

People

(Reporter: Tony Jordan, Assigned: Sean Su)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Using the 2001012906 windows installer build on Windows 98, I attempted to 
install mozilla on my machine.  For some reason, my computer consistently finds 
the chatzilla XPI to be corrupted.  Generally, I do a custom install and 
deselect Chatzilla to get around this problem. Unfortunatly, recent changes in 
the installer direct it to check integrity of all XPI files before allowing the 
user to select those components he/she wishes to install.  As a result, I cannot 
use the windows installer.

Observed: Mozilla checks and errors on chatzilla corruption (may be a unique 
problem to my system) before user has chance to deselect install of that 
component.

Expected: Mozilla should ask me what components I would like to install before 
checking the integrity

Comment 1

17 years ago
To me this bug is invalid. If a .xpi file is invalid, then please download a new 
version of the installer.
(Reporter)

Comment 2

17 years ago
Agreed, worked with ssu to solve problem.  I had a chatzilla.xpi in my install 
directory that has been "corrupting" my installs for some time.

marking invalid
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

17 years ago
verifying invalid
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.