Optimized ArrayBuffers don't deallocate reserved slots

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: nsm, Unassigned)

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

created a large array buffer so that it doesn't fit into inline slots


Actual results:

ArrayBuffer obj->slots points to allocated memory, but the reserved slots memory is not deallocated.


Expected results:

the reserved slots should be freed before allocating new slots.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
turns out this was some mis-understanding on my part.
You need to log in before you can comment on or make changes to this bug.