Last Comment Bug 669408 - Clear cache when running PGO step multiple times
: Clear cache when running PGO step multiple times
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All Linux
: -- normal (vote)
: mozilla8
Assigned To: Justin Lebar (not reading bugmail)
:
Mentors:
Depends on:
Blocks: 663251
  Show dependency treegraph
 
Reported: 2011-07-05 12:08 PDT by Justin Lebar (not reading bugmail)
Modified: 2011-07-06 18:15 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Construct a new profile each time we run an instrumented build during PGO. (1.59 KB, patch)
2011-07-05 12:09 PDT, Justin Lebar (not reading bugmail)
ted: review+
Details | Diff | Splinter Review

Description Justin Lebar (not reading bugmail) 2011-07-05 12:08:28 PDT
It seems that running the PGO step multiple times isn't having the effect I expected.

This probably isn't the reason for the lack of success, but it's simple enough to clear the profile each time we run the instrumented build.  Patch in a moment.
Comment 1 Justin Lebar (not reading bugmail) 2011-07-05 12:09:47 PDT
Created attachment 544019 [details] [diff] [review]
Construct a new profile each time we run an instrumented build during PGO.
Comment 2 Justin Lebar (not reading bugmail) 2011-07-06 12:58:11 PDT
In build-system

  http://hg.mozilla.org/projects/build-system/rev/24e8f700dfbf
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-07-06 18:15:27 PDT
http://hg.mozilla.org/mozilla-central/rev/24e8f700dfbf

Note You need to log in before you can comment on or make changes to this bug.