Address Book fields all blank and unavailable.

RESOLVED DUPLICATE of bug 654864

Status

--
major
RESOLVED DUPLICATE of bug 654864
7 years ago
7 years ago

People

(Reporter: quicksilver8, Unassigned)

Tracking

({regression, useless-UI})

Trunk
regression, useless-UI

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Also tried to Import... and loading from file abook in Profile folder. Program said: importing successful. But fields are always blank.

Comment 1

7 years ago
Bug 654864?
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110705 Firefox/7.0a1 SeaMonkey/2.4a1 ID:20110705003257

I see the same on Linux64.

Reproducible: Always

Steps to Reproduce:
1. Window → Address Book

Actual results:
The address book window opens, but it is empty. No single one of all my address books is listed.

Expected results:
Address book window should include all my address books.

Additional information:
If it makes any difference, I tried to run two SeaMonkey builds (2.4a1 and 2.5a1) built on Gecko 8.0a1 on this same profile, and came back in a hurry bacause Lightning didn't work (see bug 669834 comment #8 sqq.). I don't remember trying to use the address book in this present build before the upgrade-downgrade rigmarole.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, useless-UI
OS: Mac OS X → All
Hardware: Other → All
P.S. Even in a new profile (created and used only with this version of SeaMonkey), the "default" address books normally present in every profile are not visible. (In that case, I did "Window → Address Book" in the browser, it asked me to create a mail, news, Movemail or RSS account, I chose news, and created an account, but the address book window was still empty).
(In reply to comment #1)
> Bug 654864?

See bug 654864 comment #12:
<quote>
H. Hofer:

Thanks for the bug report!

Yes, I think the de-RDF patch broke the Seamonkey address book - but that's what this bug is all about.  For this particular problem you found, "getResourceAtIndex" is not how we go about getting the selected directory anymore.  See:

http://mxr.mozilla.org/comm-central/source/mail/components/addrbook/content/abCommon.js#616

-Mike
</quote>

I'm (tentatively) duping this to bug 654864, to which I'll Cc myself so I don't miss when it gets FIXED.

If and when it does, I'll check on Linux64 if the address book works again in SeaMonkey builds containing the fix, and Rocco (reporter) should do the same on the Mac. If it doesn't, then either this bug or bug 654864 (probably the latter) should be REOPENED by whoever sees a b0rken AB in a build containing the fix.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 654864
You need to log in before you can comment on or make changes to this bug.