Aurora Sync is enabled by default after fresh install, but I didn't enable it

RESOLVED DUPLICATE of bug 669199

Status

Firefox for Android Graveyard
General
RESOLVED DUPLICATE of bug 669199
7 years ago
7 years ago

People

(Reporter: atoll, Unassigned)

Tracking

Trunk
x86
Mac OS X

Details

Problem: After a fresh installation of Aurora 6.0a2/20110705, "Enable Sync" is set to "Yes" in the preferences.  I have not yet configured sync, so why is it enabled?  At this point, Disabling and Enabling sync results in an error message "Missing account name", rather than showing the "Add device screen".  This preference should be shown as "No" when sync is not configured.

Device: Verizon Droid 2 (stock, unrooted)
Version: Mozilla/5.0 (Android; Linux armv7l; rv:6.0a2) Gecko/20110705 Firefox/6.0a2 Fennec/6.0a2
Presuming Aurora on Android: this is related to Bug 669199, I think.

If that box is checked, it tries to log in, which of course fails for the reason you note. The whole thing is screwy.

Comment 2

7 years ago
related to bug 669199
Depends on: 669199
Duplicate of this bug: 669755
"Enable Sync" means "I want to allow Sync to function at some point". If the checkbox is unchecked, Sync will never work, even if you have an account and have logged in.

If the checkbox is checked, you are allowed to connect, or attach the device to an existing account if you have not done that already.

"Enable Sync" is from a time when Sync was slow and stalled the UI of the browser. We should just remove it altogether and create a proper Sync UI.

Perhaps the existing "Connect" button is enough.
(In reply to comment #4)
> "Enable Sync" means "I want to allow Sync to function at some point". If the
> checkbox is unchecked, Sync will never work, even if you have an account and
> have logged in.

That's not actually the case. See Bug 669199.

It might have *meant* that, but not in present tense! It performs a single operation and sets a pref which Sync doesn't know about.


> "Enable Sync" is from a time when Sync was slow and stalled the UI of the
> browser. We should just remove it altogether and create a proper Sync UI.

Bug 669199 covers removal.
(In reply to comment #5)
> (In reply to comment #4)
> > "Enable Sync" means "I want to allow Sync to function at some point". If the
> > checkbox is unchecked, Sync will never work, even if you have an account and
> > have logged in.
> 
> That's not actually the case. See Bug 669199.
> 
> It might have *meant* that, but not in present tense! It performs a single
> operation and sets a pref which Sync doesn't know about.

Correct. I was talking about the original behavior.

> > "Enable Sync" is from a time when Sync was slow and stalled the UI of the
> > browser. We should just remove it altogether and create a proper Sync UI.
> 
> Bug 669199 covers removal.

Great, I will dupe this bug to it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 669199
You need to log in before you can comment on or make changes to this bug.