Closed Bug 669589 Opened 9 years ago Closed 9 years ago

Frequent errors about server configuration and unknown errors in sync

Categories

(Firefox :: Sync, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 704539

People

(Reporter: eric.daspet, Unassigned)

References

Details

Attachments

(6 files)

I had frequent errors with Firefox Sync and Aurora (up to date). I have two frequent errors :

- Yellow banner in the bottom of the browser with "Sync a rencontré une erreur lors de la connexion : Serveur mal configuré. Veuillez essayer à nouveau" (french for something like "An error happend in sync during the connection : Bad server configuration. Please try again"). 

- Grey banner in the bottom of the browser with "Sync a rencontré une erreur lors de la synchronisation : Erreur inconnue. Sync essaiera à nouveau cette action automatiquement" (french for something like "An error happened in sync during synchronization : Unknown error. Sync will try again automatically")..

After both errors, if I discard the message and try "sync now" on the menu, the sync si working correctly ("Sync completed successfully" in the about:sync-log). it's OK for some time, then error again.

At twitter @mozservices' request, I tried to reset all my sync data with what I have in the browser. Sames errors. I even had one (the grey one) in the middle of the first sync. All logs in this bug report come from after this sync reset (but I had the same errors before). 
   
More contextual data :

- I have Aurora 6.0a2 (2011-07-04) on Mac OS X
- Modules activated : Adblock Plus 1.3.9, Add-on Compatibility Reporter 0.8.5, Feedback 1.1.2, Firebug 1.8.0b4, Read It Later 2.1.1, and Readbility 1.9 (no old sync module)
- I have other devices in sync (one Firefox Mobile on Android, one Firefox Home on IPhone, and one Firefox 4 on Windows Seven) but only the Aurora was switched on when I did my tests for this bug report (sync reset included)
- As far as I remember, I didn't had these errors with Firefox 5 when I was on the beta channel (but I may not remember them, this is not a 100% sure)
- In the weave/toFetch folder of my Firefox profile I have the following json files : bookmarks, clients, forms, history, passwords, prefs, tabs
- In the weave/changes folder of my Firefox profil I have the following json files : adblockplus, adblockplus.private, bookmarks, clients, forms, history, passwords, prefs, tabs
These are all the same error -- a mishandled network problem. Where the error occurs (during login, during sync, etc.) dictates what kind of error is reported to you.


1309892133573	Net.Resource	WARN	Caught unexpected exception Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.responseStatus] Stack trace: _onComplete()@resource://services-sync/resource.js:321 < innerBind()@resource://services-sync/util.js:1180 < Channel_onStopRequest()@resource://services-sync/resource.js:568 in _onComplete.
1309892133573	Net.Resource	DEBUG	Stack trace: _onComplete()@resource://services-sync/resource.js:321 < innerBind()@resource://services-sync/util.js:1180 < Channel_onStopRequest()@resource://services-sync/resource.js:568

What that implies is that either:

* onStopRequest was called before onStartRequest, or before a response was available (both unlikely), or
* onStopRequest was invoked with a non-error status code, but a non-successful body. That means that onComplete is called as if the request succeeded, but it did not, and so there is no HTTP status code available.


If you would like to provide better logs, you can open about:config and change

  services.sync.log.logger.network.resources

to the value

  Trace

(the capital 'T' is important). Restart Aurora, sync again until you get an error, then attach the new log. That will allow me to see some more debugging info and decide if our handling is incorrect.

As to the root cause, I'd guess that you're on a flaky wireless network, or otherwise have bad connectivity to our Phoenix, AZ, USA datacenter.

Thanks!
Thank you.

We can discard the flaky wireless explaination as it happens both at home and at work and no other app (not even browsing in the same firefox) has network problems.

I listen the potential bad connectivity, I will try to verify that one, even it is would be strange : first because it happens on two networks (home and ork) and because my home connection is at Paris with the larger french ISP (so if it had a bad connectivity, this would means a large base of french Firefox users would have the same problems).

I'll try to activate the network trace in the next days and update the report. Thanks for your time.
It was quicker than estimated.

- Activated the trace
- erased logs
- restarted browser
- 2 yellow errors
- tried to reset the sync data (start again the sync, pushing browser data to server) with success at start
- then after some time (probably before the full data is sent) grey "unknown error"

No conection oops during the test, no other devices in sync at this time.

Full trace with services.sync.log.logger.network.resources=Trace is attached
(In reply to comment #7)
> Created attachment 544310 [details]
> Sync-log with "Trace" level for network logs

That looks like a truncated log to me. Could you please set the about:config setting for Sync log rotation to false and try again? You might also see the error in about:sync-log.1, in which case please just attach that.
Attached file serverconfig error
I have this error frequently
(In reply to Tim Maks van den Broek from comment #9)
> Created attachment 577051 [details]
> serverconfig error
> 
> I have this error frequently

Tim, please don't add to another user's report; it makes it harder for us to determine separate issues.

It looks like you're experiencing Bug 690170. If you are interested, you can try installing Aurora and see if your problem goes away.

Thanks!
This is possibly fixed in bug 690170 (Firefox 10). If not, it is almost certainly fixed in bug 704539 (Firefox 12).

If you still experience the issue after upgrading, please reopen this bug.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 704539
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.