Closed Bug 669636 Opened 9 years ago Closed 8 years ago

update download notification fontcolor is black (on dark background)

Categories

(Firefox for Android Graveyard :: General, defect)

All
Other
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 9

People

(Reporter: pretzer, Assigned: alexp)

References

Details

Attachments

(2 files)

Attached image Nightly sceenshot
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

when updating nightly, the download notification text is not very readable (black fontcolor on dark background). 

Samsung Galaxy S2 (Android 2.3.3)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Alex - Can we use the Android theme voodoo to pick a better fontcolor based on the theme?

We currently hard code the textcolor: android:textColor="#ff000000"
Assignee: nobody → alexp
(In reply to comment #1)
> Alex - Can we use the Android theme voodoo to pick a better fontcolor based
> on the theme?
> 
> We currently hard code the textcolor: android:textColor="#ff000000"

Should be possible, I'll have a look at that. I still haven't yet learned all the details of those spiritual rituals.
Attached patch FixSplinter Review
This patch should do it.
I don't have a device with dark background in the notification area, but with this change the notifications seem to look exactly like the standard ones on Nexus One.

Note: this change requires API level 9 ("--with-android-sdk=.../platforms/android-9" in mozconfig).
I'm not sure how it will work on 2.1/2.2 - this needs to be tested.
Attachment #544404 - Flags: review?(blassey.bugs)
Comment on attachment 544404 [details] [diff] [review]
Fix

Review of attachment 544404 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #544404 - Flags: review?(blassey.bugs) → review+
It looks like the tinderbox server uses "android-8" SDK. Is the same used for release builds? Is there a plan to upgrade to a newer API?
(In reply to comment #5)
> It looks like the tinderbox server uses "android-8" SDK. Is the same used
> for release builds? Is there a plan to upgrade to a newer API?

Not in the short term. At least I have not heard of any.
(In reply to comment #6)
> Not in the short term. At least I have not heard of any.

The fix will not work with android-8 SDK. Notification text styles were added in Android 2.3, for API Level 9.
(In reply to comment #6)
> Not in the short term. At least I have not heard of any.

Is this really the only bug that would need a higher API level?? Would the TabletUI implementation not be a whole lot easier with the newer APIs? I mean Android is at level 13 already now, and the last levels were mainly aiming at tablets as far as i know...
(In reply to comment #8)
> Is this really the only bug that would need a higher API level?? Would the
> TabletUI implementation not be a whole lot easier with the newer APIs? I
> mean Android is at level 13 already now, and the last levels were mainly
> aiming at tablets as far as i know...

There are actually already several bugs, especially for the tablets, which require upgrade to the newer API. I guess we will need to switch to Honeycomb SDK quite soon (or even Ice Cream Sandwich SDK when it will be available).
Depends on: 676275
Since bug 676275 is fixed, can this land now?
https://hg.mozilla.org/integration/mozilla-inbound/rev/9c8c4ee78c4e
Status: NEW → ASSIGNED
Whiteboard: [inbound]
http://hg.mozilla.org/mozilla-central/rev/9c8c4ee78c4e
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → Firefox 9
i can verify the fix on my galaxy s2 (android 2.3.3)
Status: RESOLVED → VERIFIED
Duplicate of this bug: 659165
You need to log in before you can comment on or make changes to this bug.