Newsgroup names do not display on title bar.

RESOLVED DUPLICATE of bug 668959

Status

RESOLVED DUPLICATE of bug 668959
8 years ago
8 years ago

People

(Reporter: nf4l, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Clicked on a newsgroup name, ie. mozilla.support.thunderbird in the folder pane.


Actual results:

The name was not displayed on the TB title bar.


Expected results:

The name should have been displayed on the TB title bar. This occurs only for newsgroups, not email. The trigger is to select either Threads with Unread or Watched threads with Unread on the View|Threads menu item.

This did not happen in V3.1.11
(Reporter)

Updated

8 years ago
Hardware: All → x86

Comment 1

8 years ago
It appears that this applies to any folder that has no unread messages when "Threads with Unread" is selected. So it's not a newsgroup-specific issue.

Comment 2

8 years ago
This is probably a dupe of bug 668959. Does that sound right to you?
(Reporter)

Comment 3

8 years ago
(In reply to comment #1)
> It appears that this applies to any folder that has no unread messages when
> "Threads with Unread" is selected. So it's not a newsgroup-specific issue.

Not on my box. It only affects newsgroups. If, in mail, I select Threads with Unread for my inbox, then the title bar shows "Inbox - AT&T - Mozilla Thunderbird".
(Reporter)

Comment 4

8 years ago
(In reply to comment #2)
> This is probably a dupe of bug 668959. Does that sound right to you?

No. My issue is not about tabs, but the blue title bar at the top of a Windows application. Where the minimize, maximize, and close buttons are.

Comment 5

8 years ago
(In reply to comment #3)
> Not on my box. It only affects newsgroups. If, in mail, I select Threads
> with Unread for my inbox, then the title bar shows "Inbox - AT&T - Mozilla
> Thunderbird".

IMAP or POP? It seems like POP works fine, but IMAP fails in the same way as News.

(In reply to comment #4)
> No. My issue is not about tabs, but the blue title bar at the top of a
> Windows application. Where the minimize, maximize, and close buttons are.

I know, but the titles should always stay in sync (even when they're broken), and I see both the tab title and the window title having this problem.
(Reporter)

Comment 6

8 years ago
(In reply to comment #5)
> (In reply to comment #3)
> > Not on my box. It only affects newsgroups. If, in mail, I select Threads
> > with Unread for my inbox, then the title bar shows "Inbox - AT&T - Mozilla
> > Thunderbird".
> 
> IMAP or POP? It seems like POP works fine, but IMAP fails in the same way as
> News.

POP.
> 
> (In reply to comment #4)
> > No. My issue is not about tabs, but the blue title bar at the top of a
> > Windows application. Where the minimize, maximize, and close buttons are.
> 
> I know, but the titles should always stay in sync (even when they're
> broken), and I see both the tab title and the window title having this
> problem.

Ahhh... OK. I haven't/don't used multiple tabs.

Comment 7

8 years ago
If you open up the error console, do you see errors like the following when this bug manifests itself?

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIMsgDBView.numMsgsInView]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: resource:///modules/dbViewWrapper.js :: DBViewWrapper__applyViewChanges :: line 1388"  data: no]
(Reporter)

Comment 8

8 years ago
(In reply to comment #7)
> If you open up the error console, do you see errors like the following when
> this bug manifests itself?
> 
> Error: uncaught exception: [Exception... "Component returned failure code:
> 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIMsgDBView.numMsgsInView]" 
> nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame ::
> resource:///modules/dbViewWrapper.js :: DBViewWrapper__applyViewChanges ::
> line 1388"  data: no]

I cleared the error console, clicked on a newsgroup name and got this in the error console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIMsgDBView.numMsgsInView]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: resource:///modules/dbViewWrapper.js :: DBViewWrapper__applyViewChanges :: line 1388"  data: no]

Comment 9

8 years ago
Alright, that's the same problem as bug 668959 then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 668959
(Reporter)

Comment 10

8 years ago
(In reply to comment #9)
> Alright, that's the same problem as bug 668959 then.
> 
> *** This bug has been marked as a duplicate of bug 668959 ***


OK. Thanks, Jim.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 668959
You need to log in before you can comment on or make changes to this bug.