Closed Bug 669659 Opened 9 years ago Closed 9 years ago

Thunderbird can't open new windows when open on secondary monitor.

Categories

(Thunderbird :: Mail Window Front End, defect, major)

x86
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 644733

People

(Reporter: mbukh, Unassigned)

Details

I'm using 2 monitors on Mac OS X, secondary monitor placed on the left side and Thunderbird open on the secondary monitor.
When I try to reply to or view the source of an e-mail or anything that is supposed to open in a new window, no new windows appear. The name of the missing windows can be seen in the window list on the menu.
This bug seems similar to these Firefox bugs: bug 644733 and bug 632749
Whiteboard: :dupme
I am seeing this as well.

Moving Thunderbird's main window to the primary monitor has some impact: I was able to create a "Reply" window after doing so. The first "Reply" window created was just 1 pixel wide and had to be enlarged. But subsequent "Reply" windows did not exhibit this and I was able to continue creating new "Reply" windows even after moving Thunderbird back to the secondary monitor. However, I was still unable to open the "Address Book" window.
Status: UNCONFIRMED → NEW
Ever confirmed: true
That seems really weird, and I can't reproduce it with my setup (although, my secondary monitor is on my right)…

Can you both give me more details on your setup?
Are you running any extensions?
Does it still happen in safe mode?
Does it happen if you create a new profile?
What version of OS X are you running?

I'm really quite confused by this bug.

Thanks,
Blake.
FWIW, my secondary monitor is also on the left.

I am not using any extensions.

It does happen in safe mode.

It does happen after creating a new profile.

My OS version is 10.6.8.

Another detail that may or may not be helpful: As Martin noted, the missing windows *are* listed in the application's "Window" menu; however, they do *not* appear in the list of windows you see when right-clicking the application's dock icon.
I believe the key to the problem is the secondary monitor being placed on the left side. I'm guessing that the windows x-cordinates become negative, and that this is what causes the problems.

I'm not running any extensions. Same result in Safe Mode.
I'm using OS X version 10.5.8.
this is a dup.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Whiteboard: :dupme → dupme
I just tried it with the secondary monitor on the left, and still couldn't reproduce it…  :(

Are any of you using Spaces?
I'm using spaces. I just tried to turn spaces off. This made no difference.
I am using Spaces, too.

Make sure Thunderbird starts on the secondary monitor. That is, move it to the secondary monitor, maximize it, then close it and restart.
Actually the monitor on which TB starts up does not appear to make a difference (at least not for me).  As long as the new window is being opened while the message window is open on the secondary monitor, the problem arises.
I have the same problem. This is my setup:

Mac OS X 10.6.8
MacBook Pro
Dual screen setup

left screen: macbook laptop screen, in 1680x1050 mode, display profile is Color LCD
right screen: extra Mac display, in 1920x1200 mode, display profile is LED Cinema Display

The top menu bar is on the right screen, so this is my primary screen, the laptop screen is my secondary screen.

TB works fine if I start it on the primary screen, it fails (Reply, Forward, etc ... as described in the bugreport) when I start it on the secondary screen.

I am using Spaces, but all my screens are currently on canvas nr 1.

Currently I am running TB with two extensions (Lightning calendar plus Google calendar provider), but I've also tested it without any extensions with the same result.
Something that just occurred to me and might be significant: not only am I using Spaces; I have Spaces configured to have Thunderbird appear on every workspace. Anyone else have that in common?
Not me, TB is only running on workspace nr 1.
I have this same problem with Thunderbird 5 on OS X Lion (10.7). I'm using iMac (single boot).

This bug appears only when I have Thunderbird open in my left side monitor where it opens by default on my system. If I move Thunderbird to the right side monitor new windows (f.ex. reply window) can be opened. If Thunderbird is located on the left side monitor clicking f.ex. reply to email doesn't open a window.

I'm not using any extensions.

Left side monitor resolution is 1680 x 1050 and right side monitor resolution is 1920 x 1080.
Not using spaces, Mac OS 10.6.8, I keep Thunderbird on my second monitor to the left of the primary.  Can't open new window to reply or for any other action, unless I move the window more than halfway into primary monitory.

This is seemingly a very minor problem, but in reality this is a major headache :) Still trivial, still frustrating.
dupe of bug 644733 ?
Same issue here. Mac OS 10.6.8

I was able to narrow it down a bit thanks to the linked Bug #644733:
The problem only arises when Monitors are **not** top aligned!
I can confirm that the problem is not there with top aligned monitors.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 644733
Whiteboard: dupme
You need to log in before you can comment on or make changes to this bug.