Closed Bug 669666 Opened 8 years ago Closed 8 years ago

Sync UI: Connect button and status are missing

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(fennec8+)

VERIFIED FIXED
Firefox 9
Tracking Status
fennec 8+ ---

People

(Reporter: aaronmt, Assigned: mbrubeck)

Details

(Keywords: regression)

Attachments

(4 files)

Attached image Sync UI (Aurora)
Mozilla/5.0 (Android; Linux armv7l; rv:8.0a1) Gecko/20110706 Firefox/8.0a1 Fennec/8.0a1

Mozilla/5.0 (Android; Linux armv7l; rv:6.0a2) Gecko/20110706 Firefox/6.0a2 fennec/6.0a2

Device: HTC Nexus One
OS: Android 2.3.4

There used to be a connect and status under the checkbox, today they are missing. See screenshot.
OS: Mac OS X → Android
Hardware: x86 → ARM
Attached image Sync UI (Nightly)
Attachment #544269 - Attachment description: Sync UI → Sync UI (Aurora)
If this is a regression, this should be nom'd to block beta
tracking-fennec: --- → ?
Looks to be a theme issue. On my 2.2 device I don't see the problem. On 2.3 I do see the issue.
Toggling the checkbox brings the UI back.
Summary:
* Not a theme bug. Kevin saw it on 2.2 and 2.3 in an IRC discussion
* Doesn't happen all the imte. Kevin was not able to reproduce the bug at one point
* Toggling checkbox "fixes" it

So, I think we need to find out why the state is wrong when setting the row visibility. And we need the "Enable Sync" anyway.

This doesn't hurt beta enough to make a large effort to fix it there, but we will track for 8.
tracking-fennec: ? → 8+
This issue occurs on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:7.0a2)Gecko/20110717
Firefox/7.0a2 Fennec/7.0a2
Device: Motorola Droid 2
OS: Android 2.2
Attached image Screenshot - Aurora 7
Steps to reproduce:
1. Install Aurora 7 build (do not open app after it has been installed)
2. Open the stock browser
3. Browse to http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-r7/
4. Tap on any .apk file (or any other downloadable file)
5. Choose from the "Complete actions using" list Aurora app
7. Go to Preferences > Sync
8. Disable Sync and then enable it back
9. Tap on Connect button
10. Sync Aurora using the JPack Code

Actual result:
After step 7, Connect button and Sync status are missing.
After step 10, Sync is not connected. If steps 9&10 are performed again, there will be the same actual result.

Note:
Please see the following video: http://www.youtube.com/user/qaioana#p/a/u/0/kIs3janQ9H4
matt, is this something we need for 8?  can you take a look at see what is involved?
Assignee: nobody → mbrubeck
Attached patch patchSplinter Review
This happens when you open the preference panel before the first pageload finishes (so the UIReadyDelayed event hasn't fired yet).  This patch adds an extra call to WeaveGlue.init so we will call it after the first pageload finishes *or* when the pref panel opens, whichever comes first.
Attachment #557871 - Flags: review?(mark.finkle)
Attachment #557871 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mozilla-central/rev/f4dfe613ee0c
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 9
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110904
Firefox/9.0a1 Fennec/9.0a1
Device: Samsung Galaxy S
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.