Closed Bug 66967 Opened 20 years ago Closed 19 years ago

meta: libpr0n tracking bug

Categories

(Core :: ImageLib, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla1.0

People

(Reporter: pavlov, Assigned: pavlov)

References

Details

(Keywords: meta)

bugs for the new imagelib
Depends on: 66962, 66963, 66964, 66965, 66966
Depends on: mng
No longer depends on: 66963
Pavlov, I find the name of this library offensive.  Please change it or I'll be 
forced to discuss disciplinary action with brendan.
Keywords: meta
Depends on: 66977
Depends on: 66979
No longer depends on: mng, 66962, 66964, 66965, 66966
"whaah"
Summary: meta: libpr0n bugs → meta: new image library tracking bug
heh
Summary: meta: new image library tracking bug → meta: libpr0n tracking bug
Depends on: 66984
No longer depends on: 66984
I don't get it, what's wrong with that?
Depends on: 753
rotfl
It's too honest a name.
Blocks: 63750
No longer blocks: 63750
Nominate Bug 73195 to be added to the "deponds on" list.
Depends on: 73195, 73196, 73233, 73254
Depends on: 73450
Bug 73328 belongs here as well.
Depends on: 73328
*** Bug 73879 has been marked as a duplicate of this bug. ***
Depends on: 73978
Depends on: 74313
Depends on: 74333
Depends on: 74358
When bugs are added to the "depends on" list, it is VERY difficult to tell which
bug was added, because the list has become somewhat long.

I suggest that when a bug is added to also add a comment in the format:

bug # - bug description.
uhm..just mouse over it to see the summary and status?
Yeah BUT, mouseover *WHICH* new bug ???
adding bug 74293 -- "Crash (Gdk-ERROR **: XIE_FloError)"

Peter, if I am editing a different bug and I add this bug to that other bug's
"blocks" list along with my other changes, this bug will have a "depends on"
added with no comment accompanying it....
Depends on: 74293
Depends on: 74388
Depends on: 74548
That is why you need to make the extra effort to add a brief comment to this bug
when adding a "depends on" to another bug. It's really not too much to ask ;)
See bug 61015 and bug 28736 for some possible changes to bugzilla that would 
make dependency changes easier to figure out from bugmails.
*** Bug 74861 has been marked as a duplicate of this bug. ***
Depends on: 75351
Depends on: 75388
adding this morning's crashers:

bug 75388
bug 75397
bug 75407
bug 75416
Depends on: 75397, 75407, 75416
Depends on: 75558
Depends on: 74270
Status: NEW → ASSIGNED
OS: other → All
Priority: -- → P3
Hardware: PC → All
Target Milestone: --- → mozilla1.0
Depends on: 75768
adding bug 76500 to the depends list: "Limited-loop GIF anim won't stop"
Depends on: 76500
No longer depends on: 76500
Doh! I apologize for that premature dependlisting. what I SHOULD have added was
bug 75828 "Image that doesn't animate in ns4 animates in mozilla" (although I
must say I like bug 76500 's description better)
Depends on: 75828
No longer depends on: 75828
Depends on: 76504
Depends on: 73969
Depends on: 75494
Blocks: 73972
No longer blocks: 73972
Depends on: 73972
No longer depends on: 75494
Depends on: 78114
For a while now I've been unable to figure out which of the various [linux
scaling] bugs are associated with which symptoms, so I'm writing in this meta
bug and hopefully the URL can be copied to all the appropriate places

http://www.libpng.org/pub/png/png-textures.html

on Linux demonstrates a managerie of scaled PNGs and GIFs not displaying at all.
It seems like this should make it very easy to reproduce, fix and then verify
without testing all the URLs reported in DUPs. Textures 3,4,5,6 11,12 15,17,18
are not rendered (0.9.1 release Linux)
Hi 'ruth', I believe the bug you're looking
for is bug 74313

Depends on: 86883
I'm wondering if this is a libpr0n problem.  Visit the following URL...

http://www.rap.ucar.edu/weather/

The problem lies in the top banner, where it says, "Real-Time Weather Data". 
The banner should have a background image of some beautiful mammatus clouds. 
ns4 and konqueror 2.1.1 both render this correctly...moz does not.
The banner is rendered with the cloud background for me using Linux build
2001061808. (I checked it against Konqueror, and they rendered similarly.) What
build are you using?
The banner is http://www.rap.ucar.edu/weather/layout/pic1.jpg
It did not render on my trunk MacOS build, but comes up fine if I load it directly.
This is on a cvs build I did on 06/16 at 1837 PDT.  I'm going to build a new one.
OK...I did a new cvs build today (6/24) and the image renders properly now.
libpr0n has long since landed and all bugs should now be filed 
seperately for pav to ignore, this bug should probably be closed out. I 
don't think it will be too hard to verify that libpr0n 'happened'
marking fixed.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.