New MNG decoder work

RESOLVED FIXED in mozilla0.9.8

Status

()

Core
ImageLib
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Stuart Parmenter, Assigned: tor)

Tracking

({helpwanted, regression})

Trunk
mozilla0.9.8
helpwanted, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: need hot mac love, URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Bug for the new mng decoder in the new imagelib
(Reporter)

Updated

17 years ago
Blocks: 66977
(Reporter)

Updated

17 years ago
Blocks: 18574
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
OS: other → All
Hardware: PC → All
Target Milestone: --- → mozilla0.9.1
(Reporter)

Comment 1

16 years ago
is there any status on this bug?
(Assignee)

Comment 2

16 years ago
I have a prototype MNG decoder in my tree - works fine, but leaks all images.
Need to create a custom imgContainer to fix that.  I'm planning on getting
back to it before 0.9.1.

Comment 3

16 years ago
still on track for landing in the next week or so?
(Assignee)

Updated

16 years ago
Depends on: 79944
(Assignee)

Comment 4

16 years ago
Decoder checked in at modules/libpr0n/decoders/mng.  Need some Mac build help
to create the project files and do a quick test of the decoder (due to the
XP_MAC code that is needed in the image decoders).

Looking for review.
(Assignee)

Updated

16 years ago

Comment 5

16 years ago
looks like this still needs mac help. can we finish this one up in 0.9.2?
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Comment 6

16 years ago
Currently, imglib2 contains no support for MNG. Since this is the only animation
format available to webmasters who want to avoid the GIF format, it's very
important that it be implemented in time for the next release. Delaying this
delays progress for the MNG format. Even a little support (like what IE does to
PNG) is good enough to increase MNG awareness and help it work its way into
image editors and other browsers, and ultimately, become a recommendation.
Keywords: helpwanted, nsbeta1
(Assignee)

Updated

16 years ago
Whiteboard: need mac love

Comment 7

16 years ago
Actually, I should say none that is available to the browser. According to the
webpage, the authors claim that it supports MNG fully.

Comment 8

16 years ago
Tor, planning on landing this on the branch or what?
(Assignee)

Comment 9

16 years ago
hwaara: read the 2001-05-21 07:33 comment.
(Assignee)

Comment 10

16 years ago
This isn't going to happen for 0.9.2.
Target Milestone: mozilla0.9.2 → mozilla0.9.3
(Assignee)

Updated

16 years ago
Blocks: 88020

Updated

16 years ago
Keywords: mozilla0.9.3, review
(Assignee)

Comment 11

16 years ago
CCing mac people in a blatant attempt to attract mac help with project
files and testing.
Whiteboard: need mac love → need hot mac love
the trunk is dead to me until august at the earliest.

Comment 13

16 years ago
ping me again later this week when I've (hopefully) crawled out from under the
focus code's butt and finished helping brendan with the binary object dumping
(also mac help).
(Assignee)

Comment 14

16 years ago
-> 0.9.4
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Updated

16 years ago
Keywords: mozilla0.9.3 → mozilla0.9.4, regression
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5
I just tested if MNG works on Win32, and it does very well!

What needs to be done so that it's activated by default?
saari, pink: is there any chance of giving tor the Mac loving he needs?

Gerv
i'll have time only after emojo ships.

Comment 18

16 years ago
Nobody on the Mac side has had any time in FOUR MONTHS?  Jeez...didn't use to
take much longer than that to do an entire Netscape major-version-number
release. ;-)  Wish I had a Mac for this sort of testing...

Greg

Comment 19

16 years ago
I am sorry, I have just been so swamped with school. etc... My tree is full 
of gunk and it will take a while to sort this all out, I'll see what I can do 
though. If I create the files, but am not test them, would that be ok?

Zach

Comment 20

16 years ago
I have no time whatsoever to work on this. I'm working on getting 
someone on it though
(Assignee)

Updated

16 years ago
Keywords: mozilla0.9.4
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Updated

16 years ago
Blocks: 104166

Comment 21

16 years ago
Nominating for Mozilla 1.0.

Strictly speaking, this isn't a standards issue (MNG has not been formally
submitted to W3C, IETF, or ISO/IEC), but since MNG is very strongly tied to PNG
and its ability to replace GIF in all respects--and since this is a regression,
with a patch, awaiting only some final checking on one platform--I think (hope)
it qualifies.

Surely hot Mac love can't be that hard to come by... :-)

Greg
Keywords: mozilla1.0
(Assignee)

Comment 22

16 years ago
Created attachment 56444 [details] [diff] [review]
patch to throw the switch on unix and win32

Updated

16 years ago
Keywords: patch
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.7

Comment 23

16 years ago
Does this really need to wait for bug#79944 or can this be put into the trunk
(after review)?  Just wondering--I just can't wait for MNG support to return to
Mozilla!

Comment 24

16 years ago
My time is also stunning limited, but I could make Mac
project files if someone were able to explain to me
what needs to be included. Pointing me at the Windows
and or Unix Makefiles will not help much, without some
serious hand holding.

Best bet is to look for me on IRC (but not till after
thanksgiving) (or wait for Pink, who can probably do
it in 100th of the time I could)
(Assignee)

Comment 25

16 years ago
Looks like the Mac build system is switching over to XML, so I should be able
to do the Mac changes myself within a couple weeks.

Comment 26

16 years ago
Don't count on it. The XML is not easily user-editable.
(Assignee)

Comment 27

16 years ago
Ok, back to the "need hot mac love" theory.
(Reporter)

Comment 28

16 years ago
Comment on attachment 56444 [details] [diff] [review]
patch to throw the switch on unix and win32

r=pavlov
Attachment #56444 - Flags: review+

Comment 29

16 years ago
*** Bug 114068 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.8
CC'ing ccarlen, as he did the mac build conversion to xml and might be able to help.
Created attachment 61262 [details] [diff] [review]
new project and build script diffs for Mac

Here's a new xml project made completely with a text editor - no IDE required 
;-) It builds but I have not tested it. I noticed that the JPEG lib is a static
lib, it's sizeable, and it's liked with more than one thing. Couldn't it be a
shared lib and then we wouldn't have multiple copies of it in memory?
So what prevents MNG from going into 0.9.7? We have patches to get it building
on unix, win32 and mac.
The patch for unix and win32 has r= and needs sr=
The patch for mac needs r= and sr=
Thus, we could celebrate xmas with a mng-enabled Mozilla. That would be very
cool indeed.
(Assignee)

Comment 33

16 years ago
Good point - bug 114679 filed regarding the jpeg library.
Comment on attachment 56444 [details] [diff] [review]
patch to throw the switch on unix and win32

Someone should common those "Browser Content Handler" strings with a const char
[].

sr=brendan@mozilla.org

/be
Attachment #56444 - Flags: superreview+
Comment on attachment 61262 [details] [diff] [review]
new project and build script diffs for Mac

well, if conrad says it builds, r=pink.
Attachment #61262 - Flags: review+
Can someone please give sr= for the Mac patch so this can be checked in to the
trunk?

Comment 37

16 years ago
Simon: can you sr= the mac build patch?

Comment 38

16 years ago
Comment on attachment 61262 [details] [diff] [review]
new project and build script diffs for Mac

sr=sfraser
Attachment #61262 - Flags: superreview+
(Assignee)

Comment 39

16 years ago
Checked into trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 40

16 years ago
I think I speak for many in the PNG/MNG community when I say "WOO HOO!"

Thanks to everyone, Tim in particular, for getting this (back) in.  I hope to
test in the next few days (Linux only, though).

Greg
Works fine on Windows 98 SE, build 2001121803. Marking VERIFIED.
Status: RESOLVED → VERIFIED

Comment 42

16 years ago
How about testing the other platforms?
Also works on Linux (Mandrake 8.1), current CVS.

Comment 44

16 years ago
I discovered the mistake about a MNG decoder machine.
The red ingredient and the blue ingredient are reversed.
I want a developer to correct this bug.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 45

16 years ago
Open a new bug against me, including information that can be used to reproduce
the problem such as a test URL/image and the platform you're using.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 46

16 years ago
About: #44 #45

Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.7+) Gecko/20011220
OS:Windows Me(Japanese)
Mozilla's BuildID:2001122003
Mozilla's Version:0.9.7+

URL:http://mng.cocky.to/contents/temp/mngbug.htm
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 47

16 years ago
If MNG/JNG's MIME-type was 'video/mng' or 'video/jng' on the server machine, I
couldn't directly open the MNG/JNG's URLs/Files at Mozilla 0.9.7+(Win32).
(Assignee)

Comment 48

16 years ago
We don't listen for unregistered mimetypes, just the image/x-jng and
video/x-mng experimental ones.  I believe the w3c frowns on jumping
the gun on mimetypes.
(Assignee)

Comment 49

16 years ago
Hmm... I think my other win32 testers had some rare form of color blindness. :)
Ok, I know what's going wrong.  Patch coming up...

Comment 50

16 years ago
I'm sorry, I mistook about bug#66976(#45). I made the report of a bug transfer 
to a following position.
bug#66976(#44,#46) -> bug#116378
bug#66976(#47) -> bug#116381

Comment 51

16 years ago
Thank you for replying in the matter of my report(#44,#46,#47).
(Assignee)

Comment 52

16 years ago
Reclosing as win32 color problem is now bug 116378.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 53

16 years ago
By http://www.libmng.com/MNGsuite/anke_simi_img.html
it seems mng decoder does not work correctly (ICC profiles)

Comment 54

16 years ago
rpolach: that's bug 44866
You need to log in before you can comment on or make changes to this bug.