Drafts folder contents should not show in taskbar new message notification

RESOLVED DUPLICATE of bug 375717

Status

RESOLVED DUPLICATE of bug 375717
7 years ago
7 years ago

People

(Reporter: kkheller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 544383 [details]
small_taskbar_img.gif

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.112 Safari/534.30

Steps to reproduce:

Using Windows 7 and Thunderbird 5.0, I had two windows open in Thunderbird.  One window was the 'main window', and the other open window was a new draft message that i was composing.

When looking at the expandable/collapsible tree control on the left-hand side i saw:

Inbox(11)
Drafts(1)

[both were bold and highlighted blue].

So far, so good.  All of that is what I expect and what i believe to be correct behavior.

Then...  i suddenly received an incoming email message.  The new message alert is where the problem occurs. 



Actual results:

The new message alert popped up in my windows taskbar (aka system tray).  

The new message notification listed TWO SUBJECTS from TWO email messages, whereas I only actually received one incoming new message.  The second subject shown in the alert was the subject of the draft message i was still in the process of composing.

Shown here: http://i54.tinypic.com/2cz7zir.gif


Expected results:

I should have only seen ONE subject in the alert, since I only received one new message.

I was actually alarmed to see the subject line of my draft show up inside the pop-up alert.  I was planning to BCC myself on that message (which was then still a draft).  So seeing the subject line in a "new mail" alert made me think that I accidentally hit send already.
Whiteboard: dupme
know issue. Tb show old unread message (in this particural case, the draft message is the old unread message)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme
Duplicate of bug: 375717
You need to log in before you can comment on or make changes to this bug.