Closed Bug 66983 Opened 22 years ago Closed 21 years ago

[RFE] Implement a default XSLT transformation for XML documents

Categories

(Core :: XSLT, enhancement)

enhancement
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 64945

People

(Reporter: matthew, Assigned: keith)

Details

For XML documents that don't provide an XSLT link, we should apply a default one
to beautify it and allow the user to interact with it.  IE does this with a
DHTML page that colorizes the XML and lets the user collapse nodes, but I think
something more complex could be implemented in Mozilla (perhaps an XML query
engine as well?).

There should be *something* at least, rather that just stripping the XML tags
and rendering the content.  I could probably try to whip one up, but I think
there would be some minor plumbing work to associate XML documents with the
stylesheet by default.
Marking NEW.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: PC → All
Summary: Implement a default XSLT transformation for XML documents → [RFE] Implement a default XSLT transformation for XML documents
I agree... I have a stylesheet from the apache organisation that does to an xml
document exactely what IE does. I'm currently 'reworking' it to make sure it
works in Mozilla as well. 

But the issue remains that Transformiix should call this if *no* other xsl OR
css is called
dup of bug #69455?
sorry, that should be bug #64945

*** This bug has been marked as a duplicate of 64945 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
verified.

Axel
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.