Last Comment Bug 669866 - Export CXX instead of defaulting to c++
: Export CXX instead of defaulting to c++
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla8
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: 664340
  Show dependency treegraph
 
Reported: 2011-07-07 06:20 PDT by Mike Hommey [:glandium]
Modified: 2011-07-10 23:16 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Export CXX instead of defaulting to c++ (1.68 KB, patch)
2011-07-07 06:21 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-07-07 06:20:18 PDT
While looking in configure for something unrelated, I figured out what was actually going wrong with bug 664340: CXX is indeed always set by configure, but it was not reaching build/autoconf/libstdcxx.py because it was not exported.
Comment 1 Mike Hommey [:glandium] 2011-07-07 06:21:07 PDT
Created attachment 544455 [details] [diff] [review]
Export CXX instead of defaulting to c++
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-07-08 11:18:13 PDT
Comment on attachment 544455 [details] [diff] [review]
Export CXX instead of defaulting to c++

Review of attachment 544455 [details] [diff] [review]:
-----------------------------------------------------------------

Well, good. At least I know I'm not crazy for what I said on the other bug!
Comment 3 Mike Hommey [:glandium] 2011-07-10 23:16:39 PDT
http://hg.mozilla.org/mozilla-central/rev/c81d9088b48a

Note You need to log in before you can comment on or make changes to this bug.