If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Update Thunderbird install instructions

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: jenzed, Assigned: sancus)

Tracking

Details

(Reporter)

Description

6 years ago
When you download an add-on for Thunderbird, a pop-up displays instructions for installing the add-on. The third instruction needs to be updated as follows:

Click the gear icon in the top right corner and select "Install Add-on From File". Select the file you downloaded and click "OK".

Comment 1

6 years ago
This needs to be fixed urgently.  It is not at all obvious how to install a downloaded add-on, and the instructions as they currently read do not work.  Many users will conclude that it is impossible to install downloaded add-ons and give up.

However, updating the instructions as per jenzed@gmail.com's suggestions is not appropriate, because the icon looks different on different operating systems.  Apparently it looks like a gear on Windows, but on GNU/Linux it looks like a set of sliders.  The instructions would need to refer to this button in a way which is appropriate for all its incarnations.  Perhaps a better solution would be to fix the appearance of this button, or to replace or augment it with a text label.

The problems with the instruction and inconsistency in the user interface are covered in more detail at <http://thunderbirdtweaks.blogspot.com/2011/08/xpi-files-or-how-to-install-add-on-in.html>
My suggestion:
If browsing in Thunderbird, no instructions are necessary and the add-on should install via Add to Thunderbird.

If browsing outside of Thunderbird, the third step of the instructions should be:
'From the options button next to the add-on search field, select "Install Add-on From File..." and locate the downloaded add-on.'
Assignee: nobody → sancus
Duplicate of this bug: 692815

Comment 4

6 years ago
Um, how can this not be fixed over four months after it was filed? It's easy to fix -- just change some language in the install pop-up -- and it's affecting TB users every single day. I just got a complaint from the user of one of my add-ons that he couldn't figure out from the instructions how to install it. Please fix!
https://github.com/mozilla/zamboni/commit/566e29a
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.