gethostbyname() error when starting with Java plugin

VERIFIED WORKSFORME

Status

Core Graveyard
Java: OJI
VERIFIED WORKSFORME
18 years ago
8 years ago

People

(Reporter: arromdee2@yahoo.com, Assigned: Joe Chou)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I installed Java by getting the .xpm file and then opening it from Mozilla using
"File/Open File...".  When I do this and start up Mozilla, it crashes.  (Well,
it doesn't actually crash, but it hangs.)

The following is the end of the output:

Registering plugin 18 for: "application/x-java-bean;version=1.2.2","Java(tm)
Plug-in",""
Registering plugin 19 for: "application/x-java-bean;version=1.3","Java(tm)
Plug-in",""
Registering plugin 20 for:
"application/x-java-bean;jpi-version=1.3.0_01","Java(tm) Plug-in",""

**************** SERVER ERROR **************
gethostbyname() failed, errno = 2

**************** ************ **************
# # An unexpected exception has been detected in native code outside the VM.#
Program counter=0x48bea523
#
# Problematic Thread: prio=1 tid=0x80547e8 nid=0x436 runnable
#


If I use ^\ I can generate a core dump.  The stack trace in the core dump looks
like this:

(gdb)
#0  0x402bf970 in __poll ()
#1  0x4019ac1f in PRP_NakedBroadcast ()
#2  0x4019ad1d in PRP_NakedBroadcast ()
#3  0x4019bb33 in PR_GetConnectStatus ()
#4  0x4018a795 in PR_Accept ()
#5  0x40e5353c in JavaVM5::CreateRemoteJNIEnv ()
#6  0x40e503c9 in JavaPluginFactory5::CreateSecureEnv ()
#7  0x40d9a27e in NSGetModule ()
#8  0x40d9a2f2 in NSGetModule ()
#9  0x40d97ad8 in NSGetModule ()
#10 0x40d9b57c in NSGetModule ()
#11 0x40165a0f in JSJ_ConnectToJavaVM ()
#12 0x40d99111 in NSGetModule ()
#13 0x40d99728 in NSGetModule ()
#14 0x40371cdf in nsJSEnvironment::nsJSEnvironment ()
#15 0x403719bd in nsJSEnvironment::GetScriptingEnvironment ()
#16 0x40371ee2 in NS_CreateScriptContext ()
#17 0x40912c38 in NSGetModule ()
#18 0x409138b5 in NSGetModule ()
#19 0x400cccdd in nsGetInterface::operator() ()
#20 0x400cd181 in nsCOMPtr_base::assign_from_helper ()
#21 0x40423621 in inflate_mask ()
#22 0x404224d4 in inflate_mask ()
#23 0x40422874 in inflate_mask ()
#24 0x804e1a9 in JS_PushArguments ()
#25 0x804ea75 in JS_PushArguments ()
#26 0x4023ccae in __libc_start_main ()

Removing the link "libjavaplugin_oji.so" from my plugins directory causes things
to work again (without Java, of course).

Comment 1

18 years ago
works fine on linux 6.1 with branch and trunk(0129) for me. 
Assignee: av → edburns
Component: Plug-ins → OJI

Comment 2

18 years ago
Reporter could you please try again with Mozilla0.8? Please note that you will
have to workaround bug 68039 in order to install the java plugin (it's pretty
easy, but read that bug to know how to do it). Thank you!
(Reporter)

Comment 3

18 years ago
I can't find an actual 0.8, but I did retry it with a new install of the nightly
build dated February 11.  I completely deleted the old version first, and also
downloaded Java again.  After making the link to the plugins directory, I get
exactly the same error as with 0.7, except the tid and nid are different (but
they're different each time anyway) and I can't produce a core dump.  The
program counter is the same.


Comment 4

18 years ago
Xiaobin, do you have a linux machine to evaluate this?  If not, can you please 
re-assign this to Joe?
Assignee: edburns → xiaobin.lu

Comment 5

18 years ago
Joe:
   Currently I don't have a Java plugin build on Linux and I would like to 
reassign this bug to you.
   Thanks in advance!
Assignee: xiaobin.lu → joe.chou
(Assignee)

Comment 6

18 years ago
It works for me on Mozilla0.7 and the tip of branch. 
Are you able to run Netscape6 on your Linux?
Did you compile your Mozilla with debug disabled (optimized)?
(Reporter)

Comment 7

18 years ago
Downloading Netscape 6 (boy that installer is a pain) and moving the java2
directory and plugin link gives me exactly the same error in Netscape 6 as I get
in Mozilla.  Without Java, it works.

I did not compile Mozilla at all.  I downloaded the nightly build, which I
assume doesn't have debug in it.

Oh, my Linux version is Red Hat 6.0, except running the kernel from Mandrake 7.1
(2.2.15-4mdk).  I am running fvwm2, and KDE and Gnome are not installed.

Comment 8

18 years ago
Weird worksforme i dont know what to do with this one.
(Assignee)

Comment 9

18 years ago
arromdee, if Netscape6 does not work on your machine, then there may be some
problems on your machine, since Netscape6 on Linux has been out and working for
quite some time now. Have you tried Netscape's support?

Comment 10

18 years ago
Joe, can you please mark this worksforme?

Comment 11

18 years ago
Marking WORKSFORME as per edburns request.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 12

17 years ago
Verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 13

17 years ago
Upgrading to Mandrake 8.0 on a clean hard drive fixed it, so my system was
probably messed up in some unknown way which is irrelevant now.

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.