Can't create local calendar

VERIFIED INVALID

Status

Calendar
Lightning Only
VERIFIED INVALID
7 years ago
7 years ago

People

(Reporter: Jeff, Unassigned)

Tracking

Lightning 1.0b2
All
Other

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

tried to create a new local calendar.  After I enter calendar name and email address, etc. and click on "Next" button, nothing happens.  I receive following message in error console.


Actual results:

Error: Can't create calendar for 5eb31bdb-3fd0-4c14-bc2c-6356abcd27a9 (storage, moz-storage-calendar://): [Exception... "'<error>' when calling method: [calICalendar::id]"  nsresult: "0x804a0008 (<unknown>)"  location: "JS frame :: file:///C:/Users/JH/AppData/Roaming/Thunderbird/Profiles/779rvg5a.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Users/JH/AppData/Roaming/Thunderbird/Profiles/779rvg5a.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js :: cmgr_assureCache :: line 793"  data: no]


Expected results:

It should have created a new local calendar.
Hmm we should get the error logging working better here :-( This can be one of many things, including downgraded timezones. Could you try this on a new profile?
(Reporter)

Comment 2

7 years ago
Phillip--thank you for the quick reply.  I was installing Lightning and got it working but I realized it wasn't quite right and then I got confused and tried to install versions of Thunderbird and Lightening that were incompatible and I think somewhere along the way I corrupted a file or two: storage.sdb or possibly something in calendar-data folder.  Anyway, I uninstalled Lightening and Thunderbird and deleted storage.sdb and calendar-data in my profile and reinstalled everything and it seems to be working pretty close to perfect now.  I'd say the issue I reported above is resolved.  Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Glad I could help!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.