Closed Bug 670073 Opened 12 years ago Closed 12 years ago

Location bar not updated after a 301 redirect results in Untrusted Connection page

Categories

(Firefox :: Address Bar, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 623155

People

(Reporter: dholbert, Unassigned)

References

()

Details

Attachments

(2 files)

STR:
 1. Ctrl+click this link to open it in a new tab:
      http://people.mozilla.com/~dholbert/tests/301redirect/gentoo_redirect
    (This URL is set up to do a 301 redirect to https://bugs.gentoo.org)

 2. Switch to the new tab, and examine location bar

ACTUAL RESULTS:
"Untrusted Connection" page is shown, mentioning bugs.gentoo.org, but the location bar still has the original people.mozilla.com URL.

EXPECTED RESULTS:
Location bar should show the URL corresponding to the "This Connection is Untrusted", at bugs.gentoo.org.


NOTE: I also get this bug if I manually paste the gentoo_redirect URL into the location bar and hit 'enter.  However, I get EXPECTED RESULTS if I simply click the link (rather than ctrl+click), to open it in the same tab.

Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110707 Firefox/8.0a1
The location bar text is maintained entirely in front-end code...
Component: Networking → Location Bar
Product: Core → Firefox
QA Contact: networking → location.bar
Here's a screenshot to illustrate the problem.

Also, for the record -- the directory "301redirect" in the URL I've linked to is empty except for an .htaccess file with these two lines:
> RewriteEngine on
> RewriteRule gentoo_redirect https://bugs.gentoo.org/ [R=301]
That's sufficient to trigger this bug.
Attachment #544720 - Attachment description: screenshot illustrating the issue → screenshot when I control-click the link (shows the bug)
(In reply to comment #1)
> The location bar text is maintained entirely in front-end code...

OK, thanks. (Firefox|LocationBar was actually my first guess at the correct component, but I ended up picking Networking based on super-old-but-vaguely-related bug 30783.)
Not a recent regression, btw - I get the same behavior as far back as Firefox 3.5.13 (that's the oldest build I have handy).
After reproducing the bug, if you click the favicon for the "larry" dropdown, then the location bar corrects itself (changes to "https://bugs.gentoo.org/")
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.