Should remove unused lines

VERIFIED INVALID

Status

()

Core
Editor
--
minor
VERIFIED INVALID
17 years ago
13 years ago

People

(Reporter: m_kato, Assigned: m_kato)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

These lines is unused.  So we should remove.

Index: public/nsIEditorLogging.h
===================================================================
RCS file: /cvsroot/mozilla/editor/public/nsIEditorLogging.h,v
retrieving revision 1.4
diff -u -r1.4 nsIEditorLogging.h
--- nsIEditorLogging.h  2001/01/09 22:46:47     1.4
+++ nsIEditorLogging.h  2001/01/30 06:57:48
@@ -32,8 +32,6 @@
 { 0x9c, 0xe4, 0xed, 0x60, 0xbd, 0x6c, 0xb5, 0xbc } }


-class nsIFileSpec;
-
 class nsIEditorLogging : public nsISupports
 {
 public:
Index: ui/composer/locale/en-US/editor.properties
===================================================================
RCS file: /cvsroot/mozilla/editor/ui/composer/locale/en-US/editor.properties,v
retrieving revision 1.44
diff -u -r1.44 editor.properties
--- editor.properties   2001/01/19 02:34:04     1.44
+++ editor.properties   2001/01/30 06:57:50
@@ -38,10 +38,6 @@
 CantEditFramesetMsg=This editor cannot edit HTML framesets. Try editing the
page for each frame separately.
 CantEditMimeTypeMsg=This type of page can't be edited.
 CantEditDocumentMsg=This page can't be edited for some reason.
-HTMLFiles=HTML Files
-IMGFiles=Image Files
-TextFiles=Text Files
-AllFiles=All Files
 BeforeClosing=before closing
 BeforePreview=before viewing in Navigator
 # LOCALIZATION NOTE (SaveFilePrompt): Don't translate %title% and %reason%
(this is the reason for asking user to close, such as "before closing")

Updated

17 years ago
Assignee: beppe → sfraser

Comment 1

17 years ago
assigning to sfraser for confirmation of bug

Updated

17 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
nsIFileSpec and nsFileWidget is removed all from editor.
So these code does not need.

sfraser, could you review?  I have permission for check in.

Comment 3

17 years ago
You can remove the 'class nsIFileSpec'. Please don't touch the properties file; 
we left those strings in there because we will likely need them again soon.

Comment 4

17 years ago
reassign to Makoto
Assignee: sfraser → m_kato
Status: ASSIGNED → NEW
agree.   sfraser@netscape.com, could you review the following code??

Index: public/nsIEditorLogging.h
===================================================================
RCS file: /cvsroot/mozilla/editor/public/nsIEditorLogging.h,v
retrieving revision 1.4
diff -u -r1.4 nsIEditorLogging.h
--- nsIEditorLogging.h  2001/01/09 22:46:47     1.4
+++ nsIEditorLogging.h  2001/01/30 06:57:48
@@ -32,8 +32,6 @@
 { 0x9c, 0xe4, 0xed, 0x60, 0xbd, 0x6c, 0xb5, 0xbc } }


-class nsIFileSpec;
-
 class nsIEditorLogging : public nsISupports
 {
 public:
Status: NEW → ASSIGNED
This bug was last changed 2001-02-02, and it has no milestone set. Is this
problem still present ? if so please verify otherwise please close this bug.
This was already fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.