Last Comment Bug 670094 - nsAppRunner.cpp fails to compile on mingw
: nsAppRunner.cpp fails to compile on mingw
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla8
Assigned To: Jacek Caban
:
: Nathan Froyd [:froydnj]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-08 02:17 PDT by Jacek Caban
Modified: 2011-07-12 11:33 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (854 bytes, patch)
2011-07-08 02:17 PDT, Jacek Caban
roc: review+
Details | Diff | Splinter Review

Description Jacek Caban 2011-07-08 02:17:04 PDT
Created attachment 544755 [details] [diff] [review]
fix v1.0

It uses __in and __out macros that are not supported on mingw due to conflicts with GCC-provided headers. They are no-op, so removing them should be fine.
Comment 1 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-07-08 03:40:43 PDT
Comment on attachment 544755 [details] [diff] [review]
fix v1.0

Review of attachment 544755 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 2 Jacek Caban 2011-07-12 02:26:03 PDT
Thanks for review, pushed to m-i:

http://hg.mozilla.org/integration/mozilla-inbound/rev/214cd0006a0d

Note You need to log in before you can comment on or make changes to this bug.