A modified searchplugin XML file does not get updated immediately after restarting Nightly

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
3 years ago

People

(Reporter: Fanolian+bugzilla, Unassigned)

Tracking

8 Branch
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110707 Firefox/8.0a1
Build ID: 20110707030839

Steps to reproduce:

Step to reproduce:

1. Create a new profile, and open Nightly with that profile once;
2. Do a search using the bundled Google search in searchbar to make sure it is working as expected;
3. Open \Nightly\searchplugins\google.xml. Modify the domain name at both fields "template=" to a random domain (e.g. googleaaaa.com/). Save the file;
4. Restart Nightly with the created new profile. Do a search using the bundled Google search again;


Actual results:

Nightly still brings me to Google Search but not googleaaaa.com. It seems that the modified google.xml is not in effect.
Repeating step 4 a few times and the result is still the same. However if at this point I create another new profile and do a Google search, the modified google.xml comes into effect. But the original new profile is still using the unmodified google.xml.
The result is the same if I modified other searchplugins in my profile\searchplugins.
The modified google.xml may, or may not, come into effect to the original new profile after a random period of time.


Expected results:

Modified searchplugins should come into effect after one Nightly restart.
(Reporter)

Updated

7 years ago
Component: General → Search
(Reporter)

Updated

7 years ago
OS: Other → Windows 7

Comment 1

7 years ago
Works for me on:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110710 Firefox/8.0a1

I used a single clean Firefox profile. Although I did not have permissions to edit  the xml in the Firefox folder I copied and replaced it with an editable one, where I changed the string "google" to "googleaaa" as you mentioned in the description.
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Works for me on:
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110710 Firefox/8.0a1
> 
> I used a single clean Firefox profile. Although I did not have permissions
> to edit  the xml in the Firefox folder I copied and replaced it with an
> editable one, where I changed the string "google" to "googleaaa" as you
> mentioned in the description.

I follow your steps and I can get the searchplugin updated immediately as expected.
However after that I edit the google.xml like I said in the bug description, the same bug happens.
Is it possible that the bug only affects modified files but not new files?

I also find that firefox does not update the searchplugin after restarting if I edit <shortname> or <Description>. If anyone by chance reads this comment before testing, he/she can save a little bit of time by just looking at the name of the searchplugin only.

Comment 3

7 years ago
Yes, it seems to be a caching issue of some sort. If you delete the entry, restart, then add the entry back with changes then the changes are visible.

This seems to be the case in Firefox 7 as well.

Also see http://superuser.com/questions/190957/how-to-really-change-firefox-search-engine-plugins-name
Editing the default engines isn't supported, and these default engines are no longer plain files on the disk, they were moved to omni.ja in bug 1162569.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

3 years ago
(In reply to Florian Quèze [:florian] [:flo] from comment #4)
> Editing the default engines isn't supported, and these default engines are
> no longer plain files on the disk, they were moved to omni.ja in bug 1162569.

The bug also affects search plugins in [profile folder]\searchplugins, as I mentioned in the original description. The original STR used default search plugins because it was an easier method to reproduce which did not require 3rd party components back then.

I can still reproduce this bug in current (2015-09-22) Nightly for search plugins in my profile folder.

Should I open a new bug with an updated STR?
(In reply to Fanolian from comment #5)

> The bug also affects search plugins in [profile folder]\searchplugins, as I
> mentioned in the original description.

We will stop reading these files soon (see bug 1203167 for details).
You need to log in before you can comment on or make changes to this bug.