Hang of Firefox after Quicktime plugin wrongly reported as missing

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Derek Williams, Unassigned)

Tracking

11 Branch
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(9 attachments)

(Reporter)

Description

7 years ago
Created attachment 544779 [details]
firefox-bin_2011-07-08-115241_Macintosh-Quad-3GHz.hang.zip

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Clicked a link (http://academia.edu/) in Thunderbird 5 that opens a page in Firefox 5.


Actual results:

An error appears (see screenshot) showing that Quicktime is missing.  However Address bar:  About:Plugins (see screenshot) shows that Quicktime is not missing at all and actually works.  There is an exception in my own site, where some links that used to load quickly (and still do in Safari, and on all browsers under Windows 7) suffer a glacial playback speed in Firefox 4 thru 5.

Clicking Cancel:
allows the site to load normally, and there is no adverse functionality to indicate that any plugins are actually missing.  Everything works as it should.

Clicking Continue:
takes me to:  http://www.apple.com/quicktime/resources/components.html?os=OSX&ctype=71746578&csubtype=ff9c8000

This page lists very many plugin sites, but there is no guidance as to which one might fix the problem.  I have in fact downloaded and reinstalled everything that used to be in Firefox 3, including Quicktime (both as QT 7 and as QT X).

If the dialog gets hidden, it cannot be located except by pulling windows out of the way.  It does not have any identity in the Window menu of either Firefox or Thunderbird.  Once it's hidden, Firefox cannot be accessed.  Sometimes a press of the Esc key will activate the Cancel option, but quite often, the error dialog hangs and at this point, Firefox hangs ("not responding" in the Activity Monitor).  After Forcequit Firefox, and also quitting Thunderbird, the dialog continues to display with a spinning pizza cursor even though no other application apart from the Finder is still running.  Reboot of the machine is the only way to get rid of it, as it continues to display even after every single application (including the Finder) is vacated from the open list.


Expected results:

The dialog should either reveal the identity of the missing plugin accurately, and show where/how it can be updated, or not appear at all, considering that apart from the occasional hangs (attached to this post) as described above, there is no other loss of functionality.

These problems were never evident in Firefox 3 or earlier, and have all arisen since the advent of Firefox 4. The rapid succession to Firefox 5 has made no difference to the issue.
(Reporter)

Comment 1

7 years ago
Created attachment 544780 [details]
Error dialog that comes up when an external link is clicked in Thundebird to open a page in Firefox

As described, this has no effect if Cancel is clicked, and takes the user to a page full of unexplained external sites if Continue is clicked.  Esc will activate the Cancel button.  Firefox will not work until this dialog has been acknowledged, and if it hangs, Firefox does also.
(Reporter)

Comment 2

7 years ago
Created attachment 544782 [details]
About:Plugins shows that Quicktime is not missing
(Reporter)

Updated

7 years ago
Severity: normal → major
OS: Other → Mac OS X
(Reporter)

Comment 3

7 years ago
http://www.derekwilliams.net/services/composing_arranging_orchestration/

all the links to Quicktime audio on this page load very slowly by comparison with their behaviour in Safari, and all browsers on Windows 7.
(Reporter)

Comment 4

7 years ago
When I clicked this link:  http://www.matthewfields.net/audio/3clip2.mp3 I got the error message again and ofter pressing Esc, it would not play even after relaunch or refresh.  Other links at http://www.matthewfields.net/Recordings/ did play however.
WFM on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0a1) Gecko/20110711 Firefox/8.0a1

Have in mind that Firefox supports only some types of audio files, for more details please consult this link:
https://developer.mozilla.org/En/Media_formats_supported_by_the_audio_and_video_elements
(Reporter)

Comment 6

7 years ago
Thanks for the info and the link.

The problems mentioned in this post however don't occur in the Windows 7 version of Firefox 5, and did not occur in Firefox 3 and earlier on Macs.

Also when I check the About:Plugins page, it shows that all the plugins are present and up-to-date, in particular Quicktime, which is what is flagging the error since Firefox 4 came on the scene.
(Reporter)

Comment 7

7 years ago
One other point, the "don't show this again" checkbox on the missing plugin dialog is greyed out, so it repeatedly shows.  This behaviour occurs in Firefox 4-5 only, and in no other browser on either Mac or Windows OS.
(Reporter)

Comment 8

7 years ago
The issue is still present in beta 6.02
(Reporter)

Comment 9

7 years ago
I've noticed lately that whatever other application I happen to be using at the time, Firefox is wresting control from it, bringing itself into fox, with the "Apple QuickTime plug-in not found" error dialog.  Yet no matter how many times I reinstall Apple Quicktime, and check the About:Plugins page in Firefox, I am getting a clean bill of health.

None of this ever happened prior to Firefoxe Version 4.  Since then, the problem has persisted through versions 5 and 6, and all subsequent beta releases.

It's gotten so irritating that I have started using Safari instead.  Is no-one else experiencing this?
(Reporter)

Updated

7 years ago
Severity: major → critical

Comment 10

7 years ago
WFM on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0a1) Gecko/20110807 Firefox/8.0a1
(Reporter)

Comment 11

7 years ago
Created attachment 554771 [details]
This came up while I was running an unrelated application

I was setting music in the scorewriter application Sibelius 6.2.  Suddenly, I was taken to Firefox by this dialog, which I had to click either Cancel or Continue for.  The 'don't show this again button' remained greyed out no matter which option I chose.  Cancel (activated by 'Esc' key) took me direct to Firefox, even though I had attempted to switch to it.

Firefox switched me from Sibelius to itself by means of this dialog, which has not effect other than to either do nothing at all (Cancel) after which the browser works just fine, or to go to a page chockablock with links to download software (Continue).  When I check About:Plugins, there is nothing that tells me any of my plug-ins are out of date.

Again, this dialog started appearing only since version 4 of Firefox on Mac (not on Windows 7) and has peristed through 5 to 6.
(Reporter)

Comment 12

7 years ago
Created attachment 554839 [details]
Hang report of Firefox 7.0 beta after fail to Quit

Now on Firefox 7.  Checked about:plugins then http://www.mozilla.com/en-US/plugincheck/

Kept saying Shockwave out of date.  I twice downloaded and installed the updater, but even after restarting Firefox still said "out of date".  I again quit Firefox, Uninstalled Shockwave and reinstalled it.  That was when I discovered the Firefox had not fully quit, only closed all the open site tabs.  I tried to quit again, but no luck.  In Activity Monitor I discovered it had hung.  See Hang report attached.0

Relaunched Firefox again, and only then did it say "Shockwave Director up to date".

There is also a message that says "Java not up to date" so I go to http://www.java.com/en/download/manual.jsp

But there it says it's all automatically done by the Mac OS, and to use Software Updater, so I have run the Software Updater, but when I did that, it said "Your software is up to date".

It seems none of the developers whose work affects the products of other developers ever talk to each other.

This happens every time there is a software update, something always gets broken.
(Reporter)

Updated

7 years ago
Version: 5 Branch → 7 Branch

Comment 13

6 years ago
Reporter, do you have anything new about this issue?
Thanks
(Reporter)

Comment 14

6 years ago
I checked again the About:Plugins, and it took me to http://www.mozilla.org/en-US/plugincheck/, where again it told me Java was out of date.  I clicked the Update Now button and it took me to http://www.java.com/en/download/manual.jsp

At that site it states the following:
"Apple supplies their own version of Java. Use the Software Update feature (available on the Apple menu) to check that you have the most up-to-date version of Java for your Mac."

I went to Apple Software Update, however this reported all software as being up to date.

Therefore this issue was not resolved.

Silverlight plug-in was listed as "potentially out of date".  I clicked the Update button which took me to http://www.microsoft.com/getsilverlight/get-started/install/default.aspx

This reported as follows:
An earlier version of Silverlight has been detected.
Installed version: Silverlight 4 (4.0.60531.0)
Current version: Silverlight 4 (4.0.60831.0)

I downloaded and installed this, and will post back after Firefox restarts.
Version: 7 Branch → 8 Branch
(Reporter)

Comment 15

6 years ago
Created attachment 569115 [details]
Download dialog for Silverlight Plug-in

I am attaching the following new images:
Silverlight download, with Save in focus and highlighted
After Save clicked:
Browser dialog out of focus with Save and Cancel disabled
After dialog clicked on to bring it to the front
Browser dialog in focus with Save and Cancel enabled.
(Reporter)

Comment 16

6 years ago
Created attachment 569116 [details]
Save As Browser out of focus with Save and Cancel disabled
(Reporter)

Comment 17

6 years ago
Created attachment 569119 [details]
Save As Browser in focus with Save and Cancel enabled
(Reporter)

Comment 18

6 years ago
Created attachment 569121 [details]
List of unknown plug-ins.
(Reporter)

Comment 19

6 years ago
The switch to the Apple Quicktime error seems to have stopped now.  Hasn't happened in the past week, so may be resolved.
(Reporter)

Updated

6 years ago
Version: 8 Branch → 11 Branch
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Updated

6 years ago
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.