problem running runescape with seamonkey 2.2 site Java not loading

RESOLVED WORKSFORME

Status

SeaMonkey
General
P1
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: dave, Unassigned)

Tracking

SeaMonkey 2.2 Branch
All
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:5.0) Gecko/20110706 Firefox/5.0 SeaMonkey/2.2
Build ID: 20110706120824

Steps to reproduce:

I have just updated to seamonkey 2.2 and I now find java will not start.
I have tried to reinstall both programs ( seamonkey 2.2 and Java Version 6 Update 26 )



Actual results:

I keep getting messages something wrong java not working
if I used explorer 9 it runs oK
I have my checked windows program list and it shows both seamonkey and java.
I have rechecked the seamonkey java flag it is enabled.
I have cleaned out cache's.
but still no luck
could you please tell me if there is an issue with seamonkey, java or both.
and how to fix.
Im running win7 ultimate intel duo with 4mb ram
I am forced to use ie9 which i dont like at the best of times
site = www.runescape.com
runescape requires java to open and run and all I get is a black screen stating "java not installed"
any help appreciated.



Expected results:

I have played runescape games for 3years using seamonkey as my preferred browser and have had this happen once before when a seamonkey version was changed.
I should get a login screen and run runescape.

Comment 1

7 years ago
Go to Tools->Addons.
Go to the Plugins tab.
Is Java listed there? Is it enabled?
(Reporter)

Updated

7 years ago
OS: Other → Windows 7
Priority: -- → P3
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Go to Tools->Addons.
> Go to the Plugins tab.
> Is Java listed there? Is it enabled?

Thank you for you prompt response I have already checked that and yes it is there and enabled.
It is strange that everything was working ok pryor to the update to the new version of seamonkey 2.1
thats why I suspect there may be an issue with that version.ihave even downloaded firefox new version and it will not run.

Comment 3

7 years ago
Ah well SeaMonkey 2.2 uses the same browser engine as Firefox 5 so it appears that Runescape doesn't like either.

Comment 4

7 years ago
According to this page:
http://services.runescape.com/m=forum/forums.ws?25,26,637,62971675
you can try:

Allow more memory to your java.

Windows

1. Start > Search > Open Control Panel > Programs > Java
2. Select the 'Java' tab on the window that appears. You should see two panes.
3. Select 'View' under the first panel, which will be labelled ‘Java Applet Runtime Settings'.
4. You will now see your installed Java versions. In the fourth column (titled 'Runtime Parameters') double click and you will have a text entry box.
5. Type - Xmx128m into the box. The 128 part tells Java to use up to 128mb of RAM instead of the default, which is much lower. To allow more memory or less, replace 128 to 200m
(Reporter)

Comment 5

7 years ago
Hi
Have tried this with the same result.
Dave.B
Severity: normal → major
Priority: P3 → P1

Comment 6

7 years ago
OK, lets do something drastic. Uninstall all versions of Java you have in your system.

Restart your Windows OS.

Install only the latest Java SE.
(Reporter)

Comment 7

7 years ago
Hi Philip
I have followed your instructions to the letter
even used a program called JavaRA which is supposed to removal all java on my system.

Restarted and reloaded java "jre-6u26-windows-i586.exe"
Restated again after the reload
Still have the same problems.

Thanks for your help much appreciated.
(Reporter)

Updated

7 years ago
Severity: major → critical

Comment 8

7 years ago
> I have rechecked the seamonkey java flag it is enabled.

The Java "flag" (& assume you mean Edit | Preferences | Advanced -> Enable Java) is ineffectual.

To enable/disable Java you need to go to Tools | Add-ons Manager -> Plugins, & enable the Java features found there.

I see you have done that.

Do other Java sites work?
Does this correctly report your Java version, http://www.javatester.org/version.html ?

If you create a new, clean Profile, start SeaMonkey, verify that Java is enabled, does http://www.runescape.com/game.ws?autocreate=true&ab=1&j=1 work?

When I loaded the game (or whatever it is), it prompted to allow (something or the other, saying it would have full access to my computer - I'm not familiar with Java), which I granted (don't ask me why!), & then the game proceeded to load, stopping at a "This is your first time ... Auto Setup" screen, at which point, I stopped.

So it seems to be working on my end.

Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20110706 Firefox/5.0 SeaMonkey/2.2
(Reporter)

Comment 9

7 years ago
Thank you to all that tried to help me with this problem.
I have just downloaded the new java 1.7 this seems to have fixed the issue.
So I believe the problem was in Jave.
All that are having simular problems I suggest installing the new version
Thanks againg to all, this matter is now closed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.