Closed Bug 670133 Opened 11 years ago Closed 11 years ago

Tab auto-resizing does not respect browser.tabs.animate option

Categories

(Firefox :: Tabbed Browser, defect)

5 Branch
All
Other
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 649671

People

(Reporter: mozilla, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Firefox 5 introduced new behaviour when tabs are closed. The tabs retain their original width until the cursor is moved our of the tab bar. Only then do they resize. This general behaviour is discussed separately in bug #667607.



Actual results:

The resizing of the tabs after the cursor is moved is always animated, even if the user has set browser.tabs.animate to false.


Expected results:

This feature should respect the user's setting of browser.tabs.animate. If this is set to false, the tabs should resize as soon as the cursor leaves the tab bar, and should snap to their new length without animation.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 649671
You need to log in before you can comment on or make changes to this bug.