Spellcheck-as-you-type un-marks all errors after correcting one

RESOLVED DUPLICATE of bug 1154791

Status

RESOLVED DUPLICATE of bug 1154791
8 years ago
4 years ago

People

(Reporter: bash, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

After typing out my message I go through and correct the spelling errors that are underlined. When I right-click one error and correct it, for example correct "adn" to "and", all of the spelling error underlines disappear, on all words, leaving me to manually scan for where errors may exist.


Actual results:

Similar to bug https://bugzilla.mozilla.org/show_bug.cgi?id=342536 although the steps for recreating that bug do not trigger the problem.
Others report the problem as well: http://getsatisfaction.com/mozilla_messaging/topics/spellcheck_un_marks_all_errors_after_correcting_one?utm_content=topic_link&utm_medium=email&utm_source=reply_notification

Bug has existed for a very long time as indicated by when I first reported it above.
And the bug exists in -safe-mode (see http://support.mozillamessaging.com/en-US/kb/Safe-Mode ) ?
Jeremy, do you still see this?

I'm not having success reproducing
Flags: needinfo?(bash)
(Reporter)

Comment 3

5 years ago
I think so. Unfortunately it's not a constant, so I'm going by memory and had gotten used to it. I'll keep an eye out and report back. It's hard to check against safe mode also since it's not frequent enough to warrant staying in safe mode all day.

Comment 4

4 years ago
As far as we know, fixed with bug 1100966 and bug 1154791.
Try a daily version.

If the problem persists, give **EXACT** steps to reproduce.

Comment 5

4 years ago
Not fixed. Typed this in the latest alpha

This is a testt of the in line spelll check. Will see if reallly fixed.

There are three red underlined words (testt - spelll - reallly)

If I right click on the middle word, spelll, it corrects; however the red underline for testt un-marks.

Needs work.

Using latest alpha in OSX 10.10.3
James or Javi, does this fail for you on Mac with Thunderbird daily builds


> latest alpha

you mean 40.0a1 aka Daily?
(alpha isn't a term we commonly use - because we have multiple release channels)

RobertJ's testscase works for me on Windows daily 40.0a1 (2015-04-22)
Flags: needinfo?(leofigueres)
Flags: needinfo?(jamesrome)

Comment 7

4 years ago
Created attachment 8599393 [details]
Video showing that it does work.

What's alpha? Aurora (alpha) is currently at TB39. I said daily, as of today or yesterday, TB 40. I see it fixed, watch the video.

Comment 8

4 years ago
Clarification. Tested on 39.0a2 (2015-04-29). 

I'm used to the FF designations in which nightly is 40.0a1 (2015-04-29) which uses the alpha designation.

Would be helpful if the FF and TB designations were the same (:
Firefox and Thunderbird use similar designations:
a1 = Firefox Nightly, Thunderbird Daily
a2 = aurora for both Fx and Tb
b1, b2, etc = beta for Fx and Tb

alpha is not a term commonly used by people who work in code, the bugs, or in official support channels. 
If you see it being used elsewhere, they haven't caught up with the times.

ref: 
https://wiki.mozilla.org/Firefox/Channels
https://www.mozilla.org/en-US/thunderbird/channel/
https://nightly.mozilla.org/
Flags: needinfo?(bash)

Comment 10

4 years ago
(In reply to RobertJ from comment #8)
> Clarification. Tested on 39.0a2 (2015-04-29). 

That's not working. This is the fix:
https://bugzilla.mozilla.org/show_bug.cgi?id=1154791#c32

Landed only on Mozilla40, so you need to try a TB daily.

Comment 11

4 years ago
Ran my test using

This is a testt of the in line spelll check. Will see if reallly fixed.

On thunderbird-40.0a1.en-US.mac

All seems good.

Comment 12

4 years ago
Its OK on my Mac with 38.0
Flags: needinfo?(jamesrome)

Comment 13

4 years ago
Its OK on my Mac with 38.0
(In reply to James Rome from comment #13)
> Its OK on my Mac with 38.0

Same on 40a1 (trunk).
Flags: needinfo?(leofigueres)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1154791
You need to log in before you can comment on or make changes to this bug.