Mozilla/Transformiix crashes

VERIFIED FIXED

Status

()

Core
XSLT
--
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Markus Hübner, Assigned: peterv)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(10 attachments)

(Reporter)

Description

18 years ago
With the latest transformiix binaries and Mozilla 2001012904 it crashes at
http://www.world-direct.com/mozilla/index.asp
(Reporter)

Comment 1

18 years ago
Created attachment 23804 [details]
the xml file
(Reporter)

Comment 2

18 years ago
Created attachment 23805 [details]
the relating xsl file
(Reporter)

Comment 3

18 years ago
Created attachment 23806 [details]
a xsl include file
(Reporter)

Comment 4

18 years ago
Created attachment 23807 [details]
the javascript file referenced in the xsl file that loads the stylesheet file depending on the browser
(Reporter)

Comment 5

18 years ago
Created attachment 23808 [details]
the stylesheet file
(Reporter)

Comment 6

18 years ago
Created attachment 23809 [details]
the new xml file ... removed some lines
(Reporter)

Comment 7

18 years ago
The line that causes the crash is
<xsl:apply-templates select="display_data/featured_articles"/>
in the XSL file.
Severity: normal → critical
(Reporter)

Comment 8

18 years ago
Created attachment 23810 [details]
new index.xsl without any JS calls, hence no CSS import

Comment 9

18 years ago
This doesn't crash when using the standalone processor, 
BUT:
the result document contains ONLY text nodes, just a #transformiix node plus
alot of text.

This seems completely wrong, don't know offhand why the HTML node isn't created

Axel
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

18 years ago
Did a bad when testing on standalone :-(.
It works ok when using the standalone. You can even get rid of the include, btw.

The segfault is in:

#0  0xfc9ed1f4 in XMLDOMUtils::getNodeValue (node=0x8a96f8, target=0xffbec788)
    at /tmp/mozilla/extensions/transformiix/source/xml/XMLDOMUtils.cpp:158
#1  0xfc9e04cc in NodeSet::stringValue (this=0x8b1850, str=@0xffbec788)
    at /tmp/mozilla/extensions/transformiix/source/xpath/NodeSet.cpp:352
#2  0xfca2ac2c in XSLTProcessor::processAction (this=0x756718, node=0x8b0748, 
    xslAction=0x8b1c78, ps=0x6c3510)

The first one, yielding
article.asp?articleNr=2
is ok, but then I crash in the getNodeType of the above statement.
No time to check if the wrapper is created allright then, because the 
nsNodeList returns a non-null node, so I suspect the wrapper code.

Gotta run, OSDEM is taking it's first toll

Axel
(Assignee)

Comment 11

18 years ago
Two issues, one is inside the wrappers, the other is XMLDOMUtils::getNodeValue
doesn't return the value of a CDATASectionNode. Taking over.
Assignee: kvisco → peterv
(Assignee)

Comment 12

18 years ago
Created attachment 23838 [details]
Simplified stylesheet (index.xsl)
(Assignee)

Comment 13

18 years ago
Created attachment 23839 [details]
Simplified testcase (index.xml)
(Assignee)

Comment 14

18 years ago
Hmm, fucked up the mimetype of the testcase. Should have been text/xml. BTW
Markus, this is what I call a simplified testcase.
Status: NEW → ASSIGNED
(Assignee)

Comment 15

18 years ago
Created attachment 23842 [details] [diff] [review]
Proposed fix.
(Assignee)

Comment 16

18 years ago
Fixed. Looking for a review.

Comment 17

18 years ago
I agree with the changes to XMLDOMUtils.cpp, but I don't know anything about the 
wrapper code.

--Keith

Comment 18

18 years ago
r=me, check it in.

Axel
(Assignee)

Comment 19

18 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 20

18 years ago
verified. nuff said
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.