Enable <ESC> to dismiss attachment reminder notification bar when composing

RESOLVED DUPLICATE of bug 648256

Status

RESOLVED DUPLICATE of bug 648256
7 years ago
5 years ago

People

(Reporter: godfreye, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.19) Gecko/2011032020 Camino/2.0.7 (like Firefox/3.0.19)
Build ID: 2011032020

Steps to reproduce:

(1) Enable attachment reminders triggered by keywords in the text by checking the "Check for missing attachments" box under <Preferences-Composition-General>.
(2) Use any of the keywords in composing a message that will trigger the reminder.


Actual results:

The yellow reminder ribbon appears at the bottom of the compose message window as it should, but to dismiss it you have to take the time to manoever your mouse to exactly hit the teeny-tiny "x" button in the far right bottom corner. There is no other way to do it, and this is very aggravating and time-consuming.


Expected results:

Hit the <Escape> key to dismiss the reminder when it appears. "Remind Me Later" doesn't solve the problem, just postpones it until you click "Send." Using escape would be fast, and fits Apple programming norms. I tried submitting this as a suggestion (not a bug) over a year ago, and was disappointed when TBird 5.0 appeared without this behavior; it obviously got lost in the shuffle. This change isn't glitzy, but is a major irritant for me in using Thunderbird. The attachments reminder is convenient and I like to use it even though it rarely applies, but without being able to dismiss it easily the only alternative is to disable the reminder option, which is too bad. Hope someone can do the small amount of programming to fix this problem. Thanks!
Whiteboard: dupme

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme
Duplicate of bug: 648256
Summary: Enable <esc> to dismiss attachment reminder window in composing → Enable <ESC> to dismiss attachment reminder notification bar when composing
You need to log in before you can comment on or make changes to this bug.